Closed Bug 828243 Opened 9 years ago Closed 9 years ago

Cleanup wasDone, wasInProgress and endTime usage

Categories

(Firefox :: Downloads Panel, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 21
Tracking Status
firefox20 --- verified

People

(Reporter: mano, Assigned: mano)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
I also found out that we don't show the end-time at all in the library (and that we're going to have a nightmare with history downloads regarding that matter), but I'll file that in a separate bug.
Attachment #699693 - Flags: review?(mak77)
Attachment #699693 - Flags: review?(mak77) → review+
OS: Mac OS X → All
Hardware: x86 → All
https://hg.mozilla.org/mozilla-central/rev/262ee9b69e38
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 699693 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Downloads panel feature
User impact if declined: performance issues
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Limited to the feature
String or UUID changes made by this patch: none
Attachment #699693 - Flags: approval-mozilla-aurora?
Attachment #699693 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on Firefox 20 on Windows 7, Ubuntu 12.04 and Mac OS X 10.8:
Build ID: 20130326150557
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
You need to log in before you can comment on or make changes to this bug.