Huge negative number shown for data usage in notification area

VERIFIED FIXED

Status

Firefox OS
Gaia::Cost Control
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: whimboo, Assigned: salva, NeedInfo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, blocking-basecamp:-, b2g18- verified, b2g18-v1.0.1 verified)

Details

(Whiteboard: [O2 SIM][Orange SIM][Plus SIM][TD-9595])

Attachments

(5 attachments, 3 obsolete attachments)

(Reporter)

Description

5 years ago
Created attachment 699754 [details]
screenshot

As seen by the screenshot we show a totally weird number as data usage in the notification area. This starts to happen with the next restart after an upgrade. Right after an upgrade the area is totally busted and shows the same failures as bug 828271.

Not sure if it could become a b2g blocker or not. But given that so far only SIM cards not needed for our first launch are affected it might be a post blocker.
Ehh...let's still send this through triage. That number looks...scary.
blocking-basecamp: --- → ?

Updated

5 years ago
Component: Gaia::System → Gaia::Cost Control
QA Contact: carlos.martinez
We will not ship on O2
blocking-basecamp: ? → -

Comment 3

5 years ago
The graph on cost control app which goes below 0.00B on Unagi Build ID: 20130123070202. Please see the screen shot attached.

Comment 4

5 years ago
Created attachment 705499 [details]
Negative Graph on the cost control app

Comment 5

5 years ago
shira? because this may be an issue for partners in other regions.

Carlos - is this a problem for v1.0/v1.0.1?
blocking-b2g: --- → shira?
Flags: needinfo?(carlos.martinez)
Keywords: qawanted
kev, this one needs v1.0.1 target market testing support as well
Flags: needinfo?(kev)
For me, if it´s still happening, is a problem for v1.0/v1.0.1. 

But this bug was opened almost one month ago and I´m not able to reproduce it in todays build (Gecko-e2abfaf.Gaia-00c0349).
Flags: needinfo?(carlos.martinez)
(Reporter)

Comment 8

5 years ago
This UI is very inconsistent for me. One time it shows something other times nothing. A click on it also doesn't work. Not sure if that is related to software updates but the behavior seems to change when the phone gets restarted.

Comment 9

5 years ago
(In reply to Joe Cheng [:jcheng] from comment #6)
> kev, this one needs v1.0.1 target market testing support as well

Joe, my assumption is that Cost Control will not be included with op2, but I am confirming.
Flags: needinfo?(kev)
hopefully andreas.utrap can provide some feedback here as well. thanks
Flags: needinfo?(andreas.utrap)
Assignee: nobody → mbudzynski
I had the same bug months ago and was not able to reproduce it since then. Can anyone confirm it's still valid?
Please re-nom if/when reproduced.
blocking-b2g: shira? → -
tracking-b2g18: ? → -
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
removing qawanted for now
Keywords: qawanted

Comment 14

5 years ago
In latest gaia version the issue reproduced twice.Please refer the attached screen shots.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 15

5 years ago
Created attachment 734557 [details]
Screen shot attached

Comment 16

5 years ago
Created attachment 734558 [details]
Screen shot attached

Comment 17

5 years ago
Created attachment 734561 [details]
Screen shot attached
Attachment #734557 - Attachment is obsolete: true
Attachment #734558 - Attachment is obsolete: true

Comment 18

5 years ago
Created attachment 734562 [details]
Screen shot attached

Comment 19

5 years ago
This issue is reproduced with non-vivo SIM card.(very random behaviour)

Comment 20

5 years ago
For now we couldn't reproduce it, but it was reproducible on Orange (260-03) and Plus (260-01) SIM crads. I observe that this was reproducible after a lot of HSDPA data usage on SIM card and when data indicator on notification bar shows above 50 MB and next after a while it was changing to negative strange values. I also noticed that this was observed after a 2 day testing on DUT.
If we reproduce it, I will attach internal log and logcat.
(Reporter)

Updated

5 years ago
Whiteboard: [O2 SIM] → [O2 SIM][Orange SIM][Plus SIM]
(Reporter)

Updated

5 years ago
status-b2g18: --- → affected

Updated

5 years ago
Whiteboard: [O2 SIM][Orange SIM][Plus SIM] → [O2 SIM][Orange SIM][Plus SIM][TD-9595]

Comment 21

5 years ago
Hi Salva,
As requested by you,i checked the ICCID of reproduced SIM card having the below value.
ICCID:8948019110772034193
I think I can reproduce this with a trusted STR. Let me try this afternoon. Going to launch, ;)
Ok, I located the problem. It is a bug in the mindgap.js module. But the STR is quite strange (although make sense). The problem reproduce when switching from one SIM to another. Lets see:

You need two SIMs. With one, you must no spend data. Let's call this SIM, SIM 0 and SIM 1 to the other one.

1- Insert SIM 1
2- Open Usage and pass the FTE selecting Never as Reset Report
3- Enable Data and surf the Internet for a while - observe you've spent data
4- Change the time to a day after to simulate a day has passed - you can change this by settings and waiting for a couple of minutes before continuing
5- Switch off the device, change to SIM 0 and switch on
6- Open Usage and pass the FTE 
7- Change the time to a day after to simulate a day has passed
8- Switch off the device, change to SIM 1 and switch on
9- Switch off the device, change to SIM 0 and switch on
10- Open Usage

Expected:
- A consumption of 0 since SIM 0 has not spent any data

Actual:
- A negative number
I'm preparing a patch. Renominating tef?
blocking-b2g: - → tef?

Updated

5 years ago
blocking-b2g: tef? → tef+
Assigning to you salva. michalbe - hopefully you can be on the hook for a quick turnaround review.
Assignee: mbudzynski → salva
Created attachment 746346 [details]
Fixig a problem in the algorithm closing a tag in mindgap.js
Attachment #746346 - Flags: review?(francisco.jordano)
Comment on attachment 746346 [details]
Fixig a problem in the algorithm closing a tag in mindgap.js

Patch looking simple and good to me.

Tried on the device and works perfectly, thanks Salva.
Attachment #746346 - Flags: review?(francisco.jordano) → review+
Master: d6ab69091492a2743b50eae24f8965e5a07c9d1c
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-b2g18-v1.0.1: --- → fixed

Updated

5 years ago
status-b2g18-v1.0.1: fixed → affected
Uplifted d6ab69091492a2743b50eae24f8965e5a07c9d1c to:
v1-train: 4840d034ff6c677f7f2151cffa068f99b44ab6be
v1.0.1: 101b189e9156d30cabe42b8d893246a12ef728ac
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed
This have introduced a bug, reopening to tracking the solution.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
See line 168 [1]:

`tags.length` is null at this point. It should be `allTags.length`

[1] https://github.com/mozilla-b2g/gaia/pull/9589/files#L0R168

Reverting in master, v1-train and v1.0.1.
Reverts:

Master revert: 036fd81d2de5ecbe2116223ba9597f3bd21c5b3a
v1-train revert: 1c13edf853549b362b334d06b35c34692dc83495
v1.0.1 revert: 57188a05fe5b669fc98bfcc18a49c9b3effdac06
status-b2g18: fixed → affected
status-b2g18-v1.0.1: fixed → affected
Created attachment 749267 [details]
Fixing a problem in the algorithm closing a tag in mindgap.js

Sending another PR without the bug
Attachment #746346 - Attachment is obsolete: true
Attachment #749267 - Flags: review?(francisco.jordano)
Attachment #749267 - Flags: review?(francisco.jordano) → review?(leo.bugzilla.gaia)

Comment 34

5 years ago
Comment on attachment 749267 [details]
Fixing a problem in the algorithm closing a tag in mindgap.js

I think we need to add the below condition
if(!allTags.length){return;}
Attachment #749267 - Flags: review?(leo.bugzilla.gaia) → review+
Better, I'm adding that with a console.error().

We should always have length when closing a tag. I'm changing and merging once solved.

Thank for your feedback Leo ;)
Master: e29317b6599f4ac51e1d86366287fcc13fd4467d
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Uplifting in order to restore previous state:

v1-train: 903320d8d127245c26aab774083b663d565f68f6
v1.0.1: ef4c2d15a247bd85c7947e2b9fd2cf6464ea2752
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed

Comment 38

5 years ago
Verified fixed on Inari Build ID: 20130515070208

Environmental  Variables:
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d06cfe7d67c2
Gaia: 0ddb515f15cbc6b74fc2742b7599d6ae74c6413f

Also verified fixed on Leo Build ID: 20130513230207

Environmental  Variables:
Kernel Date: Apr 25
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/606c4fa198c2
Gaia: 23cec618ba1ad9f39da1fc5dfa2a4df2b2d5f933

Data usage displays correctly, huge negative number does not appear.
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
status-b2g18-v1.0.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.