If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tab count indicator not indicative of private tab count

VERIFIED FIXED in Firefox 20

Status

()

Firefox for Android
Graphics, Panning and Zooming
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: bnicholson)

Tracking

unspecified
Firefox 22
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 verified, firefox21 verified, firefox22 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
This might be intentional. The tab count indicator showcases the regular tab count and not the private tab count.
(Reporter)

Comment 1

5 years ago
(When viewed from within a private tab or in about:privatebrowsing)
One solution might be to only show the count for the kind of tabs you are currently in. So for example if you have 10 normal tabs and 2 private tabs open, the counter should change from 10 to 2 if you toggle from a normal tab to a private one.
Assignee: nobody → sriram
(Reporter)

Updated

5 years ago
status-firefox20: --- → affected
status-firefox21: --- → affected
(Assignee)

Comment 3

5 years ago
Created attachment 714134 [details] [diff] [review]
Return the tab count of the current private state
Assignee: sriram → bnicholson
Status: NEW → ASSIGNED
Attachment #714134 - Flags: review?(mark.finkle)
(Assignee)

Comment 4

5 years ago
I did a grep of Tabs.getCount(), and it looks like we're only using it to update the browser toolbar count, so this patch should be safe. To make its behavior more clear, though, maybe we should rename it to getDisplayedCount?
Comment on attachment 714134 [details] [diff] [review]
Return the tab count of the current private state

I agree with the rename to getDisplayCount
Attachment #714134 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/1d136a0c8e3f
(Assignee)

Updated

5 years ago
status-firefox21: affected → fixed
Backed out:

https://hg.mozilla.org/integration/mozilla-inbound/rev/00c09b326fee
https://hg.mozilla.org/integration/mozilla-inbound/rev/014e88baa216

for

02-16 00:24:34.748 E/GeckoAppShell( 1802): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
02-16 00:24:34.748 E/GeckoAppShell( 1802): java.util.ConcurrentModificationException
02-16 00:24:34.748 E/GeckoAppShell( 1802): 	at java.util.HashMap$HashIterator.nextEntry(HashMap.java:795)
02-16 00:24:34.748 E/GeckoAppShell( 1802): 	at java.util.HashMap$ValueIterator.next(HashMap.java:827)
02-16 00:24:34.748 E/GeckoAppShell( 1802): 	at org.mozilla.gecko.Tabs.getDisplayCount(Tabs.java:105)
02-16 00:24:34.748 E/GeckoAppShell( 1802): 	at org.mozilla.gecko.BrowserToolbar.refresh(BrowserToolbar.java:1159)
(Reporter)

Comment 8

5 years ago
This good for another attempt?
status-firefox22: --- → affected
(Assignee)

Updated

5 years ago
Depends on: 844407
(Assignee)

Comment 9

5 years ago
Oops - this was landed with the wrong bug number.

The ConcurrentModificationException from comment 7 can still happen infrequently; once bug 844407 (which is r+'ed and mostly ready) lands, though, that should be fixed.

https://hg.mozilla.org/integration/mozilla-inbound/rev/cb2ccaf0b894
https://hg.mozilla.org/mozilla-central/rev/cb2ccaf0b894
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-firefox21: fixed → affected
status-firefox22: affected → fixed
Target Milestone: --- → Firefox 22
(Assignee)

Comment 10

5 years ago
Comment on attachment 714134 [details] [diff] [review]
Return the tab count of the current private state

Note that this must be uplifted with bug 844407 to fix the exception from comment 7.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 582244 (pb)
User impact if declined: tab count will show total number of tabs instead of number of tabs for the current private state
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #714134 - Flags: approval-mozilla-beta?
Attachment #714134 - Flags: approval-mozilla-aurora?
We'll wait for bug 844497 to be reviewed then.
(In reply to Lukas Blakk [:lsblakk] from comment #11)
> We'll wait for bug 844497 to be reviewed then.

Sorry, I meant bug 844407

Updated

5 years ago
Keywords: qawanted, verifyme
Comment on attachment 714134 [details] [diff] [review]
Return the tab count of the current private state

Please make sure to land bug 844407 when landing this.
Attachment #714134 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Reporter)

Comment 14

5 years ago
Looks good on trunk (03/15)
Status: RESOLVED → VERIFIED
status-firefox22: fixed → verified
Keywords: qawanted, verifyme

Updated

5 years ago
Attachment #714134 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 15

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/93755f9fbbc1
status-firefox21: affected → fixed
(Assignee)

Comment 16

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/b43e14e2b81c
status-firefox20: affected → fixed
(Reporter)

Updated

5 years ago
status-firefox20: fixed → verified
status-firefox21: fixed → verified
You need to log in before you can comment on or make changes to this bug.