Last Comment Bug 844497 - Open Location dialog should not save state when opened in a private window
: Open Location dialog should not save state when opened in a private window
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: UI Design (show other bugs)
: unspecified
: All All
: -- normal (vote)
: seamonkey2.19
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
Depends on:
Blocks: 460895 841616
  Show dependency treegraph
 
Reported: 2013-02-23 11:55 PST by neil@parkwaycc.co.uk
Modified: 2013-04-05 16:08 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Possible patch (4.32 KB, patch)
2013-02-23 11:58 PST, neil@parkwaycc.co.uk
iann_bugzilla: review+
iann_bugzilla: approval‑comm‑beta+
Details | Diff | Splinter Review
Possible patch (2.65 KB, patch)
2013-02-23 12:39 PST, neil@parkwaycc.co.uk
no flags Details | Diff | Splinter Review

Description neil@parkwaycc.co.uk 2013-02-23 11:55:57 PST
The open location dialog never saves state when you use it to open a new private window. Except in that case, if open it from a private window it still saves state.
Comment 1 neil@parkwaycc.co.uk 2013-02-23 11:58:53 PST
Created attachment 717536 [details] [diff] [review]
Possible patch

The other alternative would be to make private be "5", but I think that results in a slightly bigger patch.
Comment 2 Ian Neal 2013-02-23 12:14:01 PST
(In reply to neil@parkwaycc.co.uk from comment #1)
> Created attachment 717536 [details] [diff] [review]
> Possible patch
> 
> The other alternative would be to make private be "5", but I think that
> results in a slightly bigger patch.

I think my preference would be to have "5" being private.
Comment 3 neil@parkwaycc.co.uk 2013-02-23 12:39:10 PST
Created attachment 717539 [details] [diff] [review]
Possible patch

Unfortunately making private "5" messes up the nice numbering in ComposerCommands.js and navigator.js ;-)
Comment 4 Ian Neal 2013-02-23 13:50:32 PST
Comment on attachment 717536 [details] [diff] [review]
Possible patch

Hmmm, I agree this one is better.
Comment 5 neil@parkwaycc.co.uk 2013-02-23 16:42:37 PST
Pushed comm-central changeset 5eaf09f06d3a.
Comment 6 neil@parkwaycc.co.uk 2013-04-02 14:12:26 PDT
Comment on attachment 717536 [details] [diff] [review]
Possible patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Potential information leak
Testing completed (on m-c, etc.): Uplifted to c-a
Risk to taking this patch (and alternatives if risky): 
String changes made by this patch: None
Comment 7 neil@parkwaycc.co.uk 2013-04-05 16:08:38 PDT
http://hg.mozilla.org/releases/comm-beta/rev/73971e6fef8d

Note You need to log in before you can comment on or make changes to this bug.