Closed Bug 828485 Opened 8 years ago Closed 7 years ago

Automatic italic highlighting using / does not work with accented characters

Categories

(Thunderbird :: Message Reader UI, defect)

17 Branch
x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 106028

People

(Reporter: davidbourguignon.net, Unassigned)

References

Details

Attachments

(1 file)

Attached image bug.png
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

I wrote in an email four French words (two with a period, two without):

/Marche/
/Marche/.
/Marche./
/Marché/

I sent this email to myself...


Actual results:

In the email I received, the first two highlighted words were in italic, not the two last ones... (See screen capture in attachment.)


Expected results:

All four words should have been in italic. Thanks in advance for your help!

(See Bug 826281 for a related issue...)
This bug and bug 826281 should be bundled, probably this problem affects all of bold, italic, and underline.
some cases wfm, but other cases fail.
yet to find pattern.

/helló/ _helló_ *helló* _hello_ /hello/ *hello*
-> shows italics when received with TB, but from first word up to and including 5th word, which isn't right.

/helló/[eol]
-> does not show italics
I would expect bug 826281 and this to have the same cause
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Component: Untriaged → Message Reader UI
Depends on: 826281
Resolution: --- → DUPLICATE
Duplicate of bug: 826281
Duplicate of bug: 106028
You need to log in before you can comment on or make changes to this bug.