Closed Bug 828514 Opened 7 years ago Closed 7 years ago

Retina and Multi Monitor display issues

Categories

(Core :: Widget: Cocoa, defect)

18 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Matt_G, Unassigned)

References

(Blocks 1 open bug)

Details

Had the following report on SUMO this morning after the 18 launch. I can't verify myself. Wondering if we can get someone to try and reproduce. Let me know if you need more information from our end. Here is the report:

"I have issues with FF 18 and Retina too. My setup: Mac Book Pro 15" Retina, OSX 10.8.2. In addition to built in screen (monitor 1) I have connected a 30" screen at 2560x1600 (monitor 2) and a 24" at 1080p (monitor 3). The retina screen is scaled with the second highest resolution possible.

When I launch FF, and it opens up maximized on monitor 3, the content of web site occupies only the upper left 1/4 of the FF window. When I resize the browser it's ok. When I move the window between different monitors, content placement/size is strange, but are fixed after resizing the window on the same monitor.

When I use FF on monitor 3 and e.g. right click links, the menu opens up on monitor 1 (retina display) instead of monitor 3. So I have to move the mouse over to the other monitor to use the popup menu. :) The menu is also scaled down to very small size."
Can you ask him/her to test a Nightly build?
Component: General → Widget
Product: Firefox → Core
Will do. I'll let you know what I hear back.
There are actually a number of people with issues using two monitors with retina. Things like menus are opening on the wrong screen or at the wrong resolution, for example.
Component: Widget → Widget: Cocoa
I have the same issues on FF18 and Retina Macbook with multiple displays. I have just installed a Nightly and the drop down problem is solved (also the address bar one). Moving the window still causes some graphical glitches, although resizing the window solves them.
I have the same exact issue.  Macbook Pro 15" Retina 10.8.2 with Firefox 18.  Only started happening when I updated to Firefox 18.  I can only use the browser on the primary screen for this reason (not the attached monitor).
Duplicate of this bug: 828333
Same here, I have the issue as well. MBP 15" Retina on 10.8.2 with FF 18. Same as everyone else: Never had the problem before updating to 18.
I think most of the issues here are manifestations of bug 814434. As such, they should be fixed on the Aurora (Firefox 20) or Nightly (FF 21) channels.

If you have the external display configured to the -left- of the built-in Retina screen, rather than to the right, [many of the] problems will not occur. (See bug 814434 comment 3.)

To disable HiDPI support and thus avoid this problem (at the cost of getting poorer-quality rendering on the Retina screen), you can go to about:config and set gfx.hidpi.enabled to 1 instead of the default 2, and relaunch the browser.
The nightly build fixed the drop down menus appearing on the other screen.  However, there is still a problem with pop up windows.  When a pop up window is triggered on the external display, the pop up opens to the full width and height of the external display but the web page only appears in the top left 1/4 of the window.  The rest of the window is painted black.  When you drag the window to the retina display the black is then filled in with the rest of the website but the screen still remains in full screen.  It does not activate the OSX full screen mode, but simply enlarges to fill the screen.  This also started happening when installing Firefox 18.
Depends on: 829963
(In reply to matthewcatalano from comment #9)
> The nightly build fixed the drop down menus appearing on the other screen. 
> However, there is still a problem with pop up windows.  ...

OK, I've opened a new bug specifically for this (see bug 829963), so we can track it in its own right. If you could add a comment there with a specific example (or several) of sites where you're experiencing this, that would be helpful - thanks.
I believe the issues described here are now fixed in Nightly, by bug 814434 and bug 829963. Resolving this "WorksForMe", as I can't dupe it to two bugs at once. :)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.