Closed Bug 828633 Opened 7 years ago Closed 7 years ago

[B2G] new perma-orange in dom/sms/tests/marionette/test_strict_7bit_encoding.js

Categories

(Core :: DOM: Device Interfaces, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla21
Tracking Status
firefox20 --- fixed
firefox21 --- fixed

People

(Reporter: jgriffin, Assigned: vicamo)

References

Details

Attachments

(2 files)

This test is now timing out on both m-c and m-i.  This happened after an emulator update (bug 828186), so that's likely the cause of the problem.

Log: 

https://tbpl.mozilla.org/php/getParsedLog.php?id=18641546&tree=Mozilla-Inbound#error2

We'll probably need to disable this test.
(In reply to Jonathan Griffin (:jgriffin) from comment #0)
> This test is now timing out on both m-c and m-i.  This happened after an
> emulator update (bug 828186), so that's likely the cause of the problem.

Would you be in support of moving the emulator manifest/version json into mozilla-central and friends at some point in the future? Would make it easier to track breakage due to changes to the emulator.
Yes, I absolutely agree, I'll file a bug for this.
Also disabled:
https://hg.mozilla.org/releases/mozilla-aurora/rev/060a35932d71

This test isn't in the manifest on b2g18 so no need to disable it there.
(In reply to Jonathan Griffin (:jgriffin) from comment #2)
> Yes, I absolutely agree, I'll file a bug for this.

Does this overlap with bug#828037? 

If not overlap, should bug#828037 depend on completing the work here in bug#828633?
No, this is a WebAPI test, and bug 828037 involves Gaia UI tests.  Different test suites completely.
https://hg.mozilla.org/mozilla-central/rev/badf9c850c88
Assignee: nobody → jgriffin
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
(In reply to Jonathan Griffin (:jgriffin) from comment #6)
> No, this is a WebAPI test, and bug 828037 involves Gaia UI tests.  Different
> test suites completely.

ok, thanks.
Forgot to mark as leave-open.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: jgriffin → nobody
Assignee: nobody → vyang
Attached file Github pull request
Attachment #701697 - Flags: review?(htsai)
Attachment #701697 - Flags: review?(htsai) → review+
Depends on: 830252
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 828186
User impact if declined: No, test cases only
Testing completed (on m-c, etc.): Need bug 830252 to perform test. Verified locally.
Risk to taking this patch (and alternatives if risky): No
String or UUID changes made by this patch: N/A
Attachment #701702 - Flags: review?(jgriffin)
Attachment #701702 - Flags: approval-mozilla-aurora?
Attachment #701702 - Flags: review?(jgriffin) → review+
Attachment #701702 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Try run for 5df9cc2cb130 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=5df9cc2cb130
Results (out of 1 total builds):
    success: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/vyang@mozilla.com-5df9cc2cb130
https://hg.mozilla.org/mozilla-central/rev/02613b832b7c
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-aurora/rev/33c982b904f0

(Not this really matters since we're not building/testing b2g on Aurora anyway...)
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.