Closed Bug 829052 Opened 8 years ago Closed 8 years ago

progress is NaN when doing appcache update

Categories

(Core Graveyard :: DOM: Apps, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-basecamp:+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed)

VERIFIED FIXED
mozilla21
blocking-basecamp +
Tracking Status
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- fixed
b2g18 --- fixed

People

(Reporter: julienw, Assigned: ferjm)

Details

Attachments

(1 file)

STR:
* install a recent enough gaia so that here maps is there with its update working (ie with bug 828939 fixed)
* update here maps
=> the byte number doesn't change in the notification

I added logs and saw that we get NaN in app.progress.
julien, what's the user impact here?  Hard to know if we want to basecamp+ here.
Flags: needinfo?(felash)
Jonas indicated impact in person. This blocks because the user does have to knowledge of what resources they've used during downloading.
Flags: needinfo?(felash)
And I actually wrote it : "=> the byte number doesn't change in the notification" :-)
Assignee: nobody → ferjmoreno
Attached patch v1Splinter Review
Attachment #700650 - Flags: review?(fabrice)
Comment on attachment 700650 [details] [diff] [review]
v1

Julien, this patch works for me, but it would be great if you could also test it. Thanks!
Attachment #700650 - Flags: feedback?(felash)
Comment on attachment 700650 [details] [diff] [review]
v1

Review of attachment 700650 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/apps/src/Webapps.jsm
@@ +21,5 @@
>  Cu.import("resource://gre/modules/SystemMessagePermissionsChecker.jsm");
>  Cu.import("resource://gre/modules/AppDownloadManager.jsm");
>  
>  function debug(aMsg) {
> +  dump("-*-*- Webapps.jsm : " + aMsg + "\n");

Oops...
Attachment #700650 - Flags: review?(fabrice) → review+
Reading the patch indicates to me and comments above indicates to me ferjm confirmed this as a bug, which means we should mark this basecamp+ after talking with Jonas.

Putting a reminder on for Jonas so that we don't forget to mark the bug as such.
Flags: needinfo?(jonas)
I'll talk with Fabrice in the morning so that we can test this together with Julien.
Keywords: qawanted
QA Contact: jsmith
Btw - When Dietrich tested this, he's getting 0 KB, not NaN KB. But that's still a problem if it's always 0 KB.
Yep, 0 KB is what is displayed, NaN is what we get from the platform. I guess we have a safeguard somewhere :)
Flags: needinfo?(jonas)
Keywords: qawanted
Comment on attachment 700650 [details] [diff] [review]
v1

This fixes the bug for me, thanks Fernando !
Attachment #700650 - Flags: feedback?(felash) → feedback+
Thanks for testing Julien! I'll push it as soon as inbound is open again.
https://hg.mozilla.org/releases/mozilla-b2g18/rev/06aaf552938e
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Keywords: verifyme
Target Milestone: --- → mozilla21
Verified on 1/21 build.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.