Blocklist the Sibelius Scorch NPAPI plugin in Firefox 18 and newer on Mac

RESOLVED FIXED

Status

()

Toolkit
Blocklisting
--
critical
RESOLVED FIXED
4 years ago
a year ago

People

(Reporter: bsmedberg, Assigned: jorgev)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
In bug 828216 we discovered that the Sibelius Scorch plugin is no longer compatible with Firefox 18 and newer on Mac OS X because we removed support for the very old quickdraw graphics model for NPAPI plugins. This plugin now crashes and all versions should be hardblocked in Firefox 18 and newer on Mac. The plugin does not need to be blocked on Windows.

smichaud, can you provide the about:plugins data for the plugin so that Jorge can construct the blocklist item?
(Reporter)

Updated

4 years ago
Flags: needinfo?(smichaud)
Sibelius Scorch

    File: Scorch.plugin
    Version: 6.2.0
    Plugin for viewing Sibelius(tm) music scores http://www.sibelius.com

MIME Type                     Description     Suffixes
application/x-sibelius-score  Sibelius Score  sib,sco
Flags: needinfo?(smichaud)
(Assignee)

Comment 2

4 years ago
Blocked on staging: https://addons-dev.allizom.org/en-US/firefox/blocked/p261

Please test, giving time for the cache to refresh.
Keywords: qawanted
QA Contact: anthony.s.hughes
Confirmed staged Sibelius block is working in Firefox 18.0, 19.0b1, and 21.0a1. Tested on Mac OSX 10.7 using http://www.scoreexchange.com/scores/92265.html as the testcase.

Comment 4

4 years ago
Thanks for jumping on this all. Let's push this out on Monday, so that users aren't impacted when we unthrottle again later this week.
(Assignee)

Comment 5

4 years ago
Done: https://addons.mozilla.org/en-US/firefox/blocked/p248
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
Depends on: 879128
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.