Last Comment Bug 829054 - Blocklist the Sibelius Scorch NPAPI plugin in Firefox 18 and newer on Mac
: Blocklist the Sibelius Scorch NPAPI plugin in Firefox 18 and newer on Mac
Status: RESOLVED FIXED
: qawanted
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: x86 Mac OS X
: -- critical (vote)
: ---
Assigned To: Jorge Villalobos [:jorgev]
: Anthony Hughes (:ashughes) [GFX][QA][Mentor]
:
Mentors:
Depends on: 879128
Blocks: 828216
  Show dependency treegraph
 
Reported: 2013-01-10 08:14 PST by Benjamin Smedberg [:bsmedberg]
Modified: 2016-03-07 15:30 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Benjamin Smedberg [:bsmedberg] 2013-01-10 08:14:21 PST
In bug 828216 we discovered that the Sibelius Scorch plugin is no longer compatible with Firefox 18 and newer on Mac OS X because we removed support for the very old quickdraw graphics model for NPAPI plugins. This plugin now crashes and all versions should be hardblocked in Firefox 18 and newer on Mac. The plugin does not need to be blocked on Windows.

smichaud, can you provide the about:plugins data for the plugin so that Jorge can construct the blocklist item?
Comment 1 Steven Michaud [:smichaud] (Retired) 2013-01-10 09:10:47 PST
Sibelius Scorch

    File: Scorch.plugin
    Version: 6.2.0
    Plugin for viewing Sibelius(tm) music scores http://www.sibelius.com

MIME Type                     Description     Suffixes
application/x-sibelius-score  Sibelius Score  sib,sco
Comment 2 Jorge Villalobos [:jorgev] 2013-01-11 13:46:01 PST
Blocked on staging: https://addons-dev.allizom.org/en-US/firefox/blocked/p261

Please test, giving time for the cache to refresh.
Comment 3 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-01-11 14:58:49 PST
Confirmed staged Sibelius block is working in Firefox 18.0, 19.0b1, and 21.0a1. Tested on Mac OSX 10.7 using http://www.scoreexchange.com/scores/92265.html as the testcase.
Comment 4 Alex Keybl [:akeybl] 2013-01-13 14:55:12 PST
Thanks for jumping on this all. Let's push this out on Monday, so that users aren't impacted when we unthrottle again later this week.
Comment 5 Jorge Villalobos [:jorgev] 2013-01-14 09:28:10 PST
Done: https://addons.mozilla.org/en-US/firefox/blocked/p248

Note You need to log in before you can comment on or make changes to this bug.