Closed Bug 829180 Opened 7 years ago Closed 7 years ago

Externally opened urls may open in private browsing windows

Categories

(Firefox :: Private Browsing, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox20 - verified

People

(Reporter: nmaier, Assigned: ehsan)

References

Details

Attachments

(1 file, 1 obsolete file)

When opening an url from another application, the new tab might be opened in a private browsing window instead of a regular window. This depends, it seems, on  what window is the most recent one.

STR:
- Open Nightly
- Open a Private window
- Switch to e.g. a bugmail in Thunderbird
- Click a link in that external application
-> Link opens in the Private window (provided it was most recent)

Tested on Win7, Lion.

There are two possible solutions:
1.) Always open in a normal window. If none is around, open a new normal window
Con: Users might have wanted to open the link in a private window. But there is the copy/paste work around.

2.) Ask the user
Con: User has to make a decision.
We should always load these URLs in a normal window.
Blocks: PBnGen
No longer depends on: PBnGen
Assignee: nobody → ehsan
Attached patch Patch (v1) (obsolete) — Splinter Review
Attachment #700834 - Flags: review?(gavin.sharp)
Attached patch Patch (v2)Splinter Review
Attachment #700834 - Attachment is obsolete: true
Attachment #700834 - Flags: review?(gavin.sharp)
Attachment #700840 - Flags: review?(gavin.sharp)
<gavin> ehsan: feels like RecentWindow.getMostRecentBrowserWindow should ignore aOptions.private #ifndef MOZ_PER_WINDOW_PRIVATE_BROWSING
<ehsan> gavin: yeah, probably...
<gavin> because it never makes sense to look for a window based on privateness, and then you wouldn't have to ifdef all callers
<ehsan> gavin: agreed
<ehsan> gavin: do you want me to make that change in the same patch?
<gavin> sure
Comment on attachment 700840 [details] [diff] [review]
Patch (v2)

You can remove the #ifdef in nsBrowserContentHandler.js now.
Attachment #700840 - Flags: review?(gavin.sharp) → review+
Comment on attachment 700840 [details] [diff] [review]
Patch (v2)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): per-window PB (although technically not a regression per se)
User impact if declined: see comment 0
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): minimal
String or UUID changes made by this patch: none
Attachment #700840 - Flags: approval-mozilla-aurora?
Attachment #700840 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/1830a14dd3af
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Depends on: 841745
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (X11: Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0

Verified as fixed in Firefox 20 beta 6 (buildID: 20130320062118), new links are opened in normal window.
Status: RESOLVED → VERIFIED
I'd like to petition for this bug to be reopened. If Firefox is set up to open links in the active window and that window is a Private window, then Firefox should open links in the private window. Opening in a non-private window should be considered a bug.

I'd also like to point out that Firefox is the only browser in OSX that behaves in this way. Safari, Chrome, and Opera all open links in the active window even if that window is a Private window.
I second this bug being reopened. This is clearly a bug.
Any way to perhaps give the user a choice whether or not to consider this a bug or a feature? I personally consider links opening in normal even though user is using PB mode a bug, not a feature. Links should open in the most recently accessed window, whether PB or normal. Nearly every other browser does it as stated.
(In reply to bug from comment #16)
> Any way to perhaps give the user a choice

There's already the browser.link.open_newwindow.override.external preference. Maybe its current behavior could be changed, or it could accept new values that allow opening external links in a private window.
https://dxr.mozilla.org/mozilla-release/rev/59666a63d70019113d2e07fde2add4adcb274ce4/browser/app/profile/firefox.js#431
(In reply to Gingerbread Man from comment #17)
> (In reply to bug from comment #16)
> > Any way to perhaps give the user a choice
> 
> There's already the browser.link.open_newwindow.override.external
> preference. Maybe its current behavior could be changed, or it could accept
> new values that allow opening external links in a private window.
> https://dxr.mozilla.org/mozilla-release/rev/
> 59666a63d70019113d2e07fde2add4adcb274ce4/browser/app/profile/firefox.js#431

So there's already a way users can make this happen? How do I change my copy of Firefox to reflect this pref?
(In reply to bug from comment #18)
> So there's already a way users can make this happen?

No. Current options are to open external links
1 in the current tab
2 in a new (non-private) window
3 in a new tab in the most recent (non-private) window

My suggestion — which I rolled into your bug 1471311 — is to either change the behavior of 3 so that it works with private windows as well, or add something like
4 in a new private window
5 in a new tab in the most recent private window

> How do I change my copy of Firefox to reflect this pref?

As I said above, you can't currently get the behavior you want. But for reference, enter the following into the address bar. After bypassing the warning, double-click the preference to change its value to 1, 2, or 3 (4 and 5 won't have any effect).
about:config?filter=browser.link.open_newwindow.override.external
You need to log in before you can comment on or make changes to this bug.