Closed Bug 829198 Opened 7 years ago Closed 7 years ago

Context menu items are using a bad font size

Categories

(Firefox for Android :: General, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox21 --- verified

People

(Reporter: wesj, Assigned: wesj)

References

Details

Attachments

(2 files)

We should use a better layout here. Something that matches the default system ones better.
Attached patch PatchSplinter Review
Simple fix. I'll post a screenshot
Attachment #700593 - Flags: review?(mark.finkle)
This compares the old and new menu items. It also shows a native menu (the urlbar one) for comparison. I'll test this on an GB phone too....
Comment on attachment 700593 [details] [diff] [review]
Patch

Uplift!
Attachment #700593 - Flags: review?(mark.finkle) → review+
Comment on attachment 700593 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Been there forever since the native transition
User impact if declined: Context menus look less native and its hard to fit much text in them.
Testing completed (on m-c, etc.): Landed on mc today
Risk to taking this patch (and alternatives if risky): Tiny change, but we're using system layouts. Could affect different devices differently.
String or UUID changes made by this patch: None.
Attachment #700593 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/00175d6d4839
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 700593 [details] [diff] [review]
Patch

Given the risk evaluation and the fact that this is a longstanding issue, let's fix this in Firefox 21 to start.
Attachment #700593 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora-
Firefox 21.0a1 (2013-01-17)

The font is now as expected - as the new in the scrreenshots. Marking bug as Verified Fixed
Status: RESOLVED → VERIFIED
Depends on: 838400
You need to log in before you can comment on or make changes to this bug.