Closed Bug 838400 Opened 8 years ago Closed 8 years ago

Context menus are too compact Android 2.3 HTC Sense

Categories

(Firefox for Android :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 22
Tracking Status
firefox20 --- unaffected
firefox21 + fixed
firefox22 --- fixed
fennec 21+ ---

People

(Reporter: kbrosnan, Assigned: wesj)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached image Screenshot
Context menus are very compact and not touch friendly at all on HTC Sense Android 2.3 devices. See screenshot.
Assignee: nobody → sriram
Kevin, you mind trying this build:

http://people.mozilla.com/~wjohnston/contextmenufix.apk

I'm trying setting a minHeight on the rows in Java (overriding the one set in xml).
This looks good wesj.
tracking-fennec: ? → 21+
Attached patch PatchSplinter Review
Assignee: sriram → wjohnston
Attachment #719606 - Flags: review?
Attachment #719606 - Flags: review? → review?(sriram)
Comment on attachment 719606 [details] [diff] [review]
Patch

Looks good to me.
Attachment #719606 - Flags: review?(sriram) → review+
https://hg.mozilla.org/mozilla-central/rev/7a2ee65ecfa0
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
(In reply to Wesley Johnston (:wesj) from comment #5)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/7a2ee65ecfa0

Wes, can you please request approval for uplift on aurora in this ? It looks to be ready :)
Comment on attachment 719606 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 829198
User impact if declined: Hard to tap context menus on some devices
Testing completed (on m-c, etc.): Landed on mc long ago
Risk to taking this patch (and alternatives if risky): Low risk. Just enforcing a minimum size
String or UUID changes made by this patch: None.
Attachment #719606 - Flags: approval-mozilla-aurora?
Attachment #719606 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.