Last Comment Bug 829246 - Malformed install.rdf for Catalan xpi in Firefox 18
: Malformed install.rdf for Catalan xpi in Firefox 18
Status: RESOLVED FIXED
:
Product: Mozilla Localizations
Classification: Client Software
Component: ca / Catalan (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Eduard Gamonal
:
:
Mentors:
: 828151 829955 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-10 13:12 PST by Chris Coulson
Modified: 2013-02-19 23:10 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Catalan install.rdf (736 bytes, application/rdf+xml)
2013-01-10 13:12 PST, Chris Coulson
no flags Details

Description Chris Coulson 2013-01-10 13:12:50 PST
Created attachment 700641 [details]
Catalan install.rdf

The Catalan language pack xpi for Firefox 18 has a malformed install.rdf. There are 2 lines of whitespace at the start of the file (attached), which results in the addon manager not loading it.

It's caused by this change: http://hg.mozilla.org/releases/l10n/mozilla-release/ca/diff/3b0b37ceb8b0/browser/defines.inc
Comment 1 Toni Hermoso Pulido 2013-01-10 13:42:10 PST
Mmm, this was caused by applying patch from bug 792717 I suppose.

We can try to add it back to all defines.inc in different branches.

Ccing Gerv as well.
Comment 2 Gervase Markham [:gerv] 2013-01-11 05:10:21 PST
None of the 3 patches attached to bug 792717 patch a file called defines.inc. And the changes in those patches are not missing newlines, which it seems this change was. Perhaps it was done by hand by someone?

Gerv
Comment 3 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2013-01-12 07:56:39 PST
*** Bug 829955 has been marked as a duplicate of this bug. ***
Comment 4 Chris Coulson 2013-01-12 12:34:51 PST
Arabic has exactly the same problem too - see bug 828151

http://hg.mozilla.org/releases/l10n/mozilla-release/ar/file/497a26f71f69/browser/defines.inc
Comment 5 Chris Coulson 2013-01-14 00:29:50 PST
A quick grep shows up some more affected locales too:

chr1s@farnsworth:~/src/firefox/build-area/firefox-18.0+build1$ grep '^.\+#filter emptyLines' l10n/*/browser/defines.inc
l10n/ar/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
l10n/bn-BD/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
l10n/ca/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
l10n/fa/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
l10n/ff/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
l10n/gd/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
l10n/nso/browser/defines.inc:# This Source Code Form is subject to the terms of the Mozilla Public# License, v. 2.0. If a copy of the MPL was not distributed with this# file, You can obtain one at http://mozilla.org/MPL/2.0/.#filter emptyLines
Comment 6 Axel Hecht [:Pike] 2013-01-14 00:43:37 PST
Dwayne, can this be a bug in the translate toolkit handling of .inc files?
Comment 7 Dwayne Bailey 2013-01-14 06:34:54 PST
@Axel, almost definitely the bug fixed by https://github.com/translate/translate/commit/e0d8001989dcf891976df8bb4e17cf9c68f85a9e

@Toni using Toolkit from master or the 1.10.0.RC1 release from http://translate.sourceforge.net/snapshots/ will solve this for you.

I only spotted the bug after struggling to get Samoan language packs to build from, I think, earlier then 18. Since most people don't/can't install the language pack I was hoping the issue would just filter its way out as the release train got rid of those broken language packs.  So unfortunately I didn't audit the .inc files that had gone before the discovery.

The fix is quite obvious so could be easy to role out.  Would be nice to know if there are any remaining in Beta. Not sure what happens on release though i.e. if it is needed/easy to deploy such a fix.
Comment 8 Toni Hermoso Pulido 2013-01-14 06:53:35 PST
Thanks Dwaine! I've upgraded translate-toolkit in the server where we host our translations.

Eduard will fix defines.inc in aurora, beta and release branches.
Comment 9 Eduard Gamonal 2013-01-20 07:30:12 PST
I checked the defines.inc file in en_GB, fr and it and took them as an example to fix our files. 
changesets:
* aurora http://hg.mozilla.org/releases/l10n/mozilla-aurora/ca/rev/efde863f1e8d
* beta http://hg.mozilla.org/releases/l10n/mozilla-beta/ca/rev/3dbaa6ad48c4 and http://hg.mozilla.org/releases/l10n/mozilla-beta/ca/rev/64a556f3e8e1
* release http://hg.mozilla.org/releases/l10n/mozilla-release/ca/rev/dcaee0efd771

I don't know how to test it.
Comment 10 Axel Hecht [:Pike] 2013-01-22 07:07:06 PST
Sorry, but these patches don't do what's expected.

browser/defines.inc should look like this, with no leading whitespace:

# This Source Code Form is subject to the terms of the Mozilla Public
# License, v. 2.0. If a copy of the MPL was not distributed with this
# file, You can obtain one at http://mozilla.org/MPL/2.0/.
#filter emptyLines

#define MOZ_LANGPACK_CREATOR Mozilla.org / Softcatalà

# If non-English locales wish to credit multiple contributors, uncomment this
# variable definition and use the format specified.
#define MOZ_LANGPACK_CONTRIBUTORS <em:contributor>Softcatalà</em:contributor>

#unfilter emptyLines

Does that make sense or would you rather have someone else provide a patch?
Comment 11 Eduard Gamonal 2013-01-23 08:08:32 PST
Hi Axel,
I took en_GB and fr as an example and it didn't work. Maybe it's faster and safer if somebody more experienced provides a patch.
Thanks
Comment 12 Toni Hermoso Pulido 2013-01-28 05:51:20 PST
I've signed off in Dashboard. I assume that builds were not taking last Edu's changes. We're affecting too much users here! :(
Please, accept anyway, Axel. It's not working anyway right now (and we need to test it's not happening in beta). We can sign off more later.

Edu, you have missed .'#filter emptyLines' attached to the license string. Moreover, Axel is suggesting that the order of license info and filter should be the reverse. Overall situation now is not cute, but I think it should not be affecting the outcome and I'd dare to say that XPI should be valid with this patch applied.
Comment 13 Toni Hermoso Pulido 2013-01-29 00:31:57 PST
Fixed anyway now.
http://hg.mozilla.org/releases/l10n/mozilla-beta/ca/rev/717fbb282204
http://hg.mozilla.org/releases/l10n/mozilla-beta/ca/rev/09d35d80bae1

Let's cross fingers for next beta.
Comment 14 Toni Hermoso Pulido 2013-02-02 11:23:50 PST
We've missed 19.0b4. It's not working yet.
Comment 15 Khaled Hosny 2013-02-05 11:32:23 PST
*** Bug 828151 has been marked as a duplicate of this bug. ***
Comment 16 Toni Hermoso Pulido 2013-02-08 13:00:12 PST
19.0b5 seems to work fine :)
I guess it's unlikely there will be a 18.0.3:
http://hg.mozilla.org/releases/l10n/mozilla-release/ca
Comment 17 Toni Hermoso Pulido 2013-02-19 23:10:31 PST
I change it as fixed. Reopen if something may still be done with 18 branch.

Note You need to log in before you can comment on or make changes to this bug.