Geolocation icon still displayed in statusbar

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: gerard, Assigned: daleharvey)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:-, b2g18+)

Details

(Whiteboard: u=fx-os-user c=may-6-17 p=1)

(Reporter)

Description

5 years ago
With gecko @ 51a4cbe, gaia @ 6dad649, after killing all application that are using GPS, the geolocation icon is still *white* in statusbar. It greys once you force GPS off/on via Settings.

This is different from bug 828971.
I'm not able to reproduce it.
Here is my str:

- Boot the phone in order to have a fresh startup
- Launch camera and accept geolocation permission
- open cardview and kill camera

Then the geolocation stays white for a couple of seconds and goes gray.
(Reporter)

Comment 2

5 years ago
I can't reproduce with camera either, but I can with geoloc. Start, stop, kill, reproduce.
(In reply to Alexandre LISSY :gerard-majax from comment #2)
> I can't reproduce with camera either, but I can with geoloc. Start, stop,
> kill, reproduce.

I can't with Geoloc neither.
Status: NEW → RESOLVED
blocking-basecamp: ? → -
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(In reply to Alexandre Poirot (:ochameau) from comment #1)
> I'm not able to reproduce it.
> Here is my str:
> 
> - Boot the phone in order to have a fresh startup
> - Launch camera and accept geolocation permission
> - open cardview and kill camera
> 
> Then the geolocation stays white for a couple of seconds and goes gray.

I can replicate this on the Unagi running yesterday's build and the latest Gaia using the above steps. I need to go into settings and disable GPS there before the icon goes gray and GPS is disabled.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to Schalk Neethling [:espressive] from comment #4)
> (In reply to Alexandre Poirot (:ochameau) from comment #1)
> > I'm not able to reproduce it.
> > Here is my str:
> > 
> > - Boot the phone in order to have a fresh startup
> > - Launch camera and accept geolocation permission
> > - open cardview and kill camera
> > 
> > Then the geolocation stays white for a couple of seconds and goes gray.
> 
> I can replicate this on the Unagi running yesterday's build and the latest
> Gaia using the above steps. I need to go into settings and disable GPS there
> before the icon goes gray and GPS is disabled.

I think I've seen this bug as well, although I haven't got firm STR yet.
tracking-b2g18: --- → ?
(In reply to Jason Smith [:jsmith] from comment #5)
> > I can replicate this on the Unagi running yesterday's build and the latest
> > Gaia using the above steps. I need to go into settings and disable GPS there
> > before the icon goes gray and GPS is disabled.
> 
> I think I've seen this bug as well, although I haven't got firm STR yet.

I've been able to reproduce this fairly consistently with the following rough steps:

a) start maps app with geolocation permission enabled
b) put phone to sleep
c) put in drawer or somewhere it can't get signal for a while (say 15+ minutes)
d) icon is now stuck, won't go away even if you repeatedly kill/restart the maps app.

It does go away if you turn the GPS on/off as per comment 2.

Basically this seems to involve scenarios where maps is open (or in the background) and the phone gets put away somewhere it doesn't have a GPS signal.  Seems pretty common.
Keywords: qawanted
(In reply to Alexandre LISSY :gerard-majax from comment #0)
> With gecko @ 51a4cbe, gaia @ 6dad649, after killing all application that are
> using GPS, the geolocation icon is still *white* in statusbar. It greys once
> you force GPS off/on via Settings.
> 
> This is different from bug 828971.

This is also different from bug 836505, where the icon stays white forever.  (Hardware is still on.)

Updated

5 years ago
QA Contact: jsmith
Investigated this. Here's my hunch of what's going on.

Maps if I remember repeatedly keeps calling the geolocation API repeatedly on some repeated loop. So while the app is open, we'll probably keep doing pings against the API, resulting in showing the geolocation icon activity we are seeing.

So my hunch is that this isn't a bug on our end and likely expected behavior, as the maps app is just doing a repeated check.

We need to reproduce this on a different app to really confirm this is a bug. Otherwise, I think we're doing the right thing here.
Keywords: qawanted
Whiteboard: [INVALID?]

Updated

5 years ago
Whiteboard: [INVALID?] → [INVALID?][closeme 2/8/2013]
(In reply to Jason Smith [:jsmith] from comment #8)
> So my hunch is that this isn't a bug on our end and likely expected
> behavior, as the maps app is just doing a repeated check.

I don't think so as the notification remains after you kill the maps app.
(In reply to Lucas Adamski from comment #9)
> (In reply to Jason Smith [:jsmith] from comment #8)
> > So my hunch is that this isn't a bug on our end and likely expected
> > behavior, as the maps app is just doing a repeated check.
> 
> I don't think so as the notification remains after you kill the maps app.

Ah, okay. That behavior I'm seeing. So sounds like we've confirmed the bug then after killing the maps app.
Whiteboard: [INVALID?][closeme 2/8/2013]
This is the kind of thing that causes user fear (location, battery usage) so we'd want a fix in v1-train, tracking.
tracking-b2g18: ? → +
Assignee: nobody → dale
Whiteboard: u=fx-os-user c=may-6-17 p=0
Whiteboard: u=fx-os-user c=may-6-17 p=0 → u=fx-os-user c=may-6-17 p=1
(Assignee)

Comment 12

5 years ago
I think there is confusion about the expected behaviour, the only definite bug I had seen reported is by lsblakk and I am unable to reproduce (I have been trying a while)

So the expected behaviour is 

 * Open application that uses geolocation (maps)
 * Geolocation notification icon shows up white
 * do anything, the icon will stay white while the app uses geolocation (permanently for maps)
 * close the application, around 2-5 seconds the notification icon should turn grey
 * a minute after the icon goes grey it will dissapear

I have been trying to reproduce this for a while on various devices and cant get the notification stuck, closing for now until there are reproducable STR
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.