[toolbox] once toolbox is undocked, hide the the close button

VERIFIED FIXED in Firefox 20

Status

()

Firefox
Developer Tools: Framework
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: paul, Assigned: paul)

Tracking

Trunk
Firefox 21
x86
All
Points:
---

Firefox Tracking Flags

(firefox20 verified, firefox21 verified)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
I'm pretty sure that at some point, we supported that.
(In reply to Paul Rouget [:paul] from comment #1)
> I'm pretty sure that at some point, we supported that.

I don't think so. Looking at the history of Toolbox.jsm, I see these two lines:

let closeButton = this.doc.getElementById("toolbox-close");
closeButton.addEventListener("command", this.destroy, true);

unchanged, and nowhere else in the open() method we use closeButton variable.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 829674
(Assignee)

Comment 4

5 years ago
Created attachment 703943 [details] [diff] [review]
v1
Assignee: nobody → paul
Status: NEW → ASSIGNED
Attachment #703943 - Flags: feedback?(scrapmachines)
Comment on attachment 703943 [details] [diff] [review]
v1

Review of attachment 703943 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #703943 - Flags: feedback?(scrapmachines) → feedback+
(Assignee)

Updated

5 years ago
Attachment #703943 - Flags: review?(fayearthur)
Comment on attachment 703943 [details] [diff] [review]
v1

cool.
Attachment #703943 - Flags: review?(fayearthur) → review+
(Assignee)

Updated

5 years ago
Whiteboard: [land-in-fx-team]
(Assignee)

Comment 7

5 years ago
Comment on attachment 703943 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature (toolbox)
User impact if declined: extra close button in the UI
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): very low
String or UUID changes made by this patch: no
Attachment #703943 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/785200131a17
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/785200131a17
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 21
Comment on attachment 703943 [details] [diff] [review]
v1

low risk uplift for a new feature in FF20. approving on aurora considering where we are in the release cycle.
Attachment #703943 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
Whiteboard: [land-in-aurora]
https://hg.mozilla.org/releases/mozilla-aurora/rev/c00acb25f94f
status-firefox20: --- → fixed
status-firefox21: --- → fixed
Whiteboard: [land-in-aurora]
Verified as fixed on the latest Nightly and Aurora - when the toolbox is undocked the "Close" button is hidden.

Verified on Windows 7, Ubuntu 12.10 and Mac OS X 10.8.2:
Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130210 Firefox/21.0 (20130210031150)
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20130210 Firefox/20.0 (20130210042017)

Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20130211 Firefox/21.0 (20130211031055)
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20130210 Firefox/20.0 (20130210042017)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20130211 Firefox/21.0 (20130211031055)
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20130211 Firefox/20.0 (20130211042016)
Status: RESOLVED → VERIFIED
status-firefox20: fixed → verified
status-firefox21: fixed → verified
You need to log in before you can comment on or make changes to this bug.