[Crash Reporting] when setting set to "ask me when a crash occurs" - user is not prompted, clicking "report" in some cases invokes "Contacts" app

RESOLVED DUPLICATE of bug 822721

Status

RESOLVED DUPLICATE of bug 822721
6 years ago
6 years ago

People

(Reporter: jhammink, Unassigned)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:-, b2g18+)

Details

(Whiteboard: [CR])

(Reporter)

Description

6 years ago
Unagi gaia, nightly 1/3/13

gecko: 45f9dae82e94beec89183cd2f6b09a930b483379"

gaia: 67b917fa8146708828708cd1077ed007200fa2c9

STR:

1. Set settings => Improve Firefox OS => Crash Reports to  "Ask me when a crash occurs"
2.  Crash the phone, e.g. using adb shell kill -11 <b2g plug in container process pid>

Expected:  some kind of prompt, e.g. "Firefox Crashed - would you like to send a crash report? <yes> <no>

Actual:  No actual prompt given, instead just "just crashed" banner.  Note: tapping "report" button in some cases invokes Contacts app; otherwise button is unresponsive. 

(Report is anyways generated in /data/b2g/Crash Reports/pending but does not appear to go to /submitted folder or get sent to /crash-stats.mozilla.com)
Sounds like two bugs actually, let's use this one about the "ask me when a crash occurs." File a separate bug about the contacts app coming up unexpectedly.

Is this consistently reproducible? If it is, then this is probably a blocker.
blocking-b2g: --- → tef?
tracking-b2g18: --- → ?
(Reporter)

Updated

6 years ago
Blocks: 830023
(Reporter)

Updated

6 years ago
Blocks: 830029
blocking-b2g: tef? → -
tracking-b2g18: ? → +
Keywords: qawanted
Someone needs to retest to get more info here.
Whiteboard: [CR]
Contact app is located in the dock near where the button is placed.  I think this is the transparency bug. bug 822721
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 822721
Not too sure why it blocks 830023, 830029...  removing them from the list.

Cannot reproduce the rest of the bug; getting a crash message correctly.

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_0/rev/6153fb8e61b6
Gaia   fa9e1b55dc1048d595617d14d41b7d57f696132b
BuildID 20130201070201
Version 18.0

Removing QAWanted
No longer blocks: 830023, 830029
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.