Last Comment Bug 830427 - SVG ellipse is incorrectly rendered in Firefox
: SVG ellipse is incorrectly rendered in Firefox
Status: RESOLVED DUPLICATE of bug 814952
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: 18 Branch
: x86_64 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-14 10:54 PST by Brendan Rollinson
Modified: 2013-01-14 13:17 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Incorrectly rendered image (3.90 KB, image/png)
2013-01-14 10:55 PST, Brendan Rollinson
no flags Details
Image of related configuration (84.39 KB, image/png)
2013-01-14 10:57 PST, Brendan Rollinson
no flags Details

Description Brendan Rollinson 2013-01-14 10:54:15 PST
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120907231657

Steps to reproduce:

I created a simple web page, containing the HTML content as presented in this documentation: http://www.w3.org/TR/SVG11/shapes.html#EllipseElement

Then, I loaded the HTML page using Firefox 18.0 in Windows 7.


Actual results:

The filled-in ellipse on the left appeared correctly. However, the outlined ellipse on the right rendered as a collapsed dot rather than an ellipse.

See attached images of incorrect render.


Expected results:

The ellipse on the right should have rendered as shown on the linked page.

After some investigation, it appears that changing the "gfx.content.azure.enabled" config setting from the default value of "true" to "false" seems to fix the problem, but this is not an ideal solution.

See attached image of initial configuration.
Comment 1 Brendan Rollinson 2013-01-14 10:55:53 PST
Created attachment 701888 [details]
Incorrectly rendered image
Comment 2 Brendan Rollinson 2013-01-14 10:57:42 PST
Created attachment 701889 [details]
Image of related configuration
Comment 3 Robert Longson 2013-01-14 12:02:06 PST
Please can you attach the testcase.
Comment 4 Alice0775 White 2013-01-14 12:24:59 PST

*** This bug has been marked as a duplicate of bug 814952 ***

Note You need to log in before you can comment on or make changes to this bug.