The default bug view has changed. See this FAQ.

SVG ellipse is incorrectly rendered in Firefox

RESOLVED DUPLICATE of bug 814952

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 814952
4 years ago
4 years ago

People

(Reporter: Brendan Rollinson, Unassigned)

Tracking

18 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120907231657

Steps to reproduce:

I created a simple web page, containing the HTML content as presented in this documentation: http://www.w3.org/TR/SVG11/shapes.html#EllipseElement

Then, I loaded the HTML page using Firefox 18.0 in Windows 7.


Actual results:

The filled-in ellipse on the left appeared correctly. However, the outlined ellipse on the right rendered as a collapsed dot rather than an ellipse.

See attached images of incorrect render.


Expected results:

The ellipse on the right should have rendered as shown on the linked page.

After some investigation, it appears that changing the "gfx.content.azure.enabled" config setting from the default value of "true" to "false" seems to fix the problem, but this is not an ideal solution.

See attached image of initial configuration.
(Reporter)

Comment 1

4 years ago
Created attachment 701888 [details]
Incorrectly rendered image
(Reporter)

Comment 2

4 years ago
Created attachment 701889 [details]
Image of related configuration

Comment 3

4 years ago
Please can you attach the testcase.
Flags: needinfo?(brollinson)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 814952

Updated

4 years ago
Flags: needinfo?(brollinson)
You need to log in before you can comment on or make changes to this bug.