If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Private browsing leaking history

RESOLVED DUPLICATE of bug 830893

Status

()

Firefox for Android
General
--
major
RESOLVED DUPLICATE of bug 830893
5 years ago
a year ago

People

(Reporter: micmon, Unassigned)

Tracking

21 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Open a few tabs in private mode in current Aurora or Nightly builds. Keep the browser running in the background for a few hours. Open it again after it has been swapped out of memory and find the previously opened tabs in your browsing history.
When you say "in your browsing history", do you mean it shows up in your History tab and in your top sites? I'm not sure how that can happen, but that's a bad problem we need to fix.

Can you reproduce using oom-fennec (https://hg.mozilla.org/users/blassey_mozilla.com/oom-fennec/) rather than keeping the browser in the background for hours?
Also, are you previously opened tabs automatically restored when this happens? Or are you simply taken to about:home?
(Reporter)

Comment 3

5 years ago
I see this in my Nightly profile, which is supposed to have an empty bookmark/history db. Once the described effect happens, it gets me to about:home, which now shows the sites I had open in private before. It does not seem to try to load the previous tabs itself.
I'm having trouble reproducing this. Do you have any add-ons installed, or anything unusual about your configuration? If you're familiar with ADB, could you try reproducing this using the oom-fennec tool from comment 1?
(Reporter)

Comment 5

5 years ago
(In reply to Brian Nicholson (:bnicholson) from comment #4)
> I'm having trouble reproducing this. Do you have any add-ons installed,

AdBlock

> or anything unusual about your configuration? 

No... but I was using this profile for quite some time. Trying with a fresh one now.

> If you're familiar with ADB, could you try reproducing this using 
> the oom-fennec tool from comment 1?

Ok I will have a look
(Reporter)

Comment 6

5 years ago
Sorry I need some help: how can I execute the oom-fennec binary? I can't seem to make it executable... this is what I did:

$ adb shell
shell@android:/ $ cd /sdcard/                                                  
shell@android:/sdcard $ su
shell@android:/mnt/shell/emulated/0 # chmod 700 oom-fennec                     
shell@android:/mnt/shell/emulated/0 # ./oom-fennec                             
sh: ./oom-fennec: can't execute: Permission denied
sdcards are formatted as FAT32, so they can't work with chmod. Try putting the binary in /data/local/.
(Reporter)

Comment 8

5 years ago
Thanks... got it to work, but I was not able to trigger the bug this way. I will use my phone normally tomorrow and see if I can trigger the condition again, using the new profile
(Reporter)

Comment 9

5 years ago
I got this once today, with the fresh profile.
Looking into this bug, I found bug 830893, which may be related. Once bug 830893 is in Nightly, can you see if your problem still exists?
(Reporter)

Comment 11

5 years ago
Sure, I will keep a look at bug 830893.
Today's Nightly has Brian's patch in bug 830893. Michael, can you re-test?
(Reporter)

Comment 13

5 years ago
No problem, downloading now.
(Reporter)

Comment 14

5 years ago
Since the patch landed I have not been able to reproduce my problem on nightly. I will report back if it happens again. Hopefully this fix will make it into aurora as well.
(In reply to Michael Monreal [:monreal] from comment #14)
> Since the patch landed I have not been able to reproduce my problem on
> nightly. I will report back if it happens again. Hopefully this fix will
> make it into aurora as well.

Yep, this is a critical private browsing issue, so I've requested/landed the fix in Aurora. I'll mark this as resolved for now since it seems to be fixed, but please reopen if you can reproduce.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 830893
You need to log in before you can comment on or make changes to this bug.