Closed Bug 830893 Opened 7 years ago Closed 7 years ago

Zombified tabs lose their private states

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 21
Tracking Status
firefox20 + fixed
firefox21 --- fixed

People

(Reporter: bnicholson, Assigned: bnicholson)

References

Details

Attachments

(1 file, 1 obsolete file)

We destroy tabs and recreate them as zombie tabs here: http://hg.mozilla.org/integration/mozilla-inbound/file/8e7daee5f5a9/mobile/android/chrome/content/browser.js#l8053

In doing so, tabs lose their private state. We should remember them for the zombified tabs.
Hopefully, this is a dupe of bug 830461.
Attachment #702434 - Flags: review?(mark.finkle)
Oops, fixed a typo. I'm still doing a full rebuild and haven't been able to test this yet, but I think this should work.
Attachment #702434 - Attachment is obsolete: true
Attachment #702434 - Flags: review?(mark.finkle)
Attachment #702438 - Flags: review?(mark.finkle)
Attachment #702438 - Flags: review?(mark.finkle) → review+
Comment on attachment 702438 [details] [diff] [review]
Remember private state for zombified tabs, v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 582244
User impact if declined: zombified private tabs won't actually be private
Testing completed (on m-c, etc.): just landed m-i
Risk to taking this patch (and alternatives if risky): very low risk
String or UUID changes made by this patch: none
Attachment #702438 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/05e097a70714
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 702438 [details] [diff] [review]
Remember private state for zombified tabs, v2

Approving low risk patch, but tracking since this is something we'd really want to know about if there were regressions.
Attachment #702438 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 830461
You need to log in before you can comment on or make changes to this bug.