Last Comment Bug 830514 - Enable users to indicate that they consent to reuse of their content on WebPlatform.org
: Enable users to indicate that they consent to reuse of their content on WebPl...
Status: RESOLVED WONTFIX
:
Product: Mozilla Developer Network
Classification: Other
Component: Profiles (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 799573 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-14 14:29 PST by Janet Swisher
Modified: 2015-12-22 07:58 PST (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Janet Swisher 2013-01-14 14:29:48 PST
MDN content can be used on other sites, including WebPlatform.org, under MDN's CC-BY-SA license. However, this is not the default license on WebPlatform.org, which means that MDN content that is used there must be specially marked.

MDN users may wish to indicate that they agree to let the content they have contributed to MDN be used on WebPlatform.org under that site's contributor agreement. Or they may want to make explicit that they do not agree to that.

This would enable Webplatform.org editors to figure out whether particular content requires marking as CC-BY-SA. (I.e., if all contributors to a page have indicated consent, then it can be used under WebPlatform.org's term.)

I envision adding fields to the user profile page like this:

() I agree that content I contribute to MDN can be reused on WebPlatform.org under the terms of that site's Contributor Agreement. My WebPlatform.org user profile is: [   ]
() The content I contribute to MDN can be reused only under the default MDN license (CC-BY-SA).

If the user selects the first option, then they are required to supply a link to their WebPlatform.org user profile. This indicates that they have consented to the WebPlatform.org Contributor Agreement by creating an account.

The fields should be in the unset state (no default) until the user explicitly modifies them.
Comment 1 Janet Swisher 2013-01-17 11:54:53 PST
*** Bug 799573 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.