summary report for columns of bug list page

RESOLVED WORKSFORME

Status

()

Bugzilla
Query/Bug List
P4
enhancement
RESOLVED WORKSFORME
17 years ago
7 years ago

People

(Reporter: Andreas Franke (gone), Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
This is a feature request. 

Currently, on the bug list page, you can click on the column header to sort the
list by the selected column. It would be nice if there was a possibility to
select a column and get the distribution of bugs across the values of the
selected column as a summary report.

Example:
The bug list shows the bugzilla.mozilla.org bugs with the 4xp keyword.
You invoke the new mechanism for the assignee/owner column, and the result is:
     45 sspitzer@netscape.com
     26 av@netscape.com
     17 joki@netscape.com
     17 ben@netscape.com
    ... ...

This feature does not make sense for columns where different bugs always have
different values, e.g. bug_id, summary, status_whiteboard(?), keywords,
but is is useful for owner, bug_status & resolution, component, ...

You could either have an additional "group by" link for each column where this
feature is supported, or have one menu to select the column and a submit button.
Or you could overload the link that is already present, so that if you click on
the column for the second time (when the bug list is already sorted by this
column), then it switches to the summary report. But the overloaded behaviour
might be hard to discover.

The summary report should be sortable by each column: by count, and by the value
the bugs are grouped by. This could be done the same way it is done in bug
lists: clicking on the column header sorts by the selected column.
(Reporter)

Comment 1

17 years ago
Created attachment 36323 [details] [diff] [review]
small, quick & dirty patch that gets you part of the way
(Reporter)

Comment 2

17 years ago
Created attachment 36324 [details] [diff] [review]
same patch (to buglist.cgi), but this time as diff -u
(Reporter)

Comment 3

17 years ago
The above little patch simply counts the bugs for each owner during bug list
creation, and prints a summary table at the end of the page. 

Known problems with this patch:
- only works for "owner"
- doesn't support sorting
- summary is always displayed, not only on demand

If someone has an idea how to proceed from here, please comment.
BTW, the patch works fine with the current CVS tip.
Keywords: patch, review
targetting all bugs with patches so they show up on the radar.
Target Milestone: --- → Bugzilla 2.16

Comment 5

17 years ago
-> New Bugzilla Product
Assignee: tara → afranke

Updated

17 years ago
Component: Bugzilla → Query/Bug List
Product: Webtools → Bugzilla
Version: Bugzilla 2.13 → 2.13
(Reporter)

Comment 6

17 years ago
See also bug 77764 "Allowing to do bug counts from the query page".
Another patch which adds function which is a subset of the general reporting patch.

Gerv
(Reporter)

Comment 8

17 years ago
-> default owner. (Pulling myself out.)
Assignee: afranke → endico
Generic reporting is still on the 2.16 train; and even if it falls off, we'll
probably wait for that rather than do this.

Gerv
Keywords: patch, review
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
Comment on attachment 36324 [details] [diff] [review]
same patch (to buglist.cgi), but this time as diff -u

needs-work because its pretemplatisation.

I also don't like the way this is part of the results; it should be mreged into
reporting, or something.
Attachment #36324 - Flags: review-
*** Bug 224940 has been marked as a duplicate of this bug. ***
Assignee: endico → nobody
enhancements without current patches are being pushed to 2.20
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22

Updated

12 years ago
Assignee: nobody → query-and-buglist
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: Bugzilla 2.22 → ---

Updated

11 years ago
Priority: -- → P4

Comment 14

7 years ago
This is possible now with report.cgi.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.