Find/search does not work in XML (or XSL) file

RESOLVED DUPLICATE of bug 449235

Status

()

RESOLVED DUPLICATE of bug 449235
6 years ago
6 years ago

People

(Reporter: sypachev_s_s, Unassigned)

Tracking

18 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 702154 [details]
bug1.png

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151925

Steps to reproduce:

Open XML-like file (XML or XSL), then tries to search for a word


Actual results:

Search engine (SE) doesn't open imploded tags, and doesn't search inside of them. Also, doesn't find all items. "Prev" button doesn't work. "Highlugh all" doesn't work. After reload it doesn't find even those words which were found before, unless clear search input and re-enter search phrase.
P.S. When external tools are used (hence firebug) when focus on tool window then xml document turn into plain text.


Expected results:

When I try to find word or a part of word in XML document SE should find them all, unless otherwise specified. It also should find previous, and next, and all words together.

Comment 1

6 years ago
Please add a link to a testcase (an XML file).

There are older reports of find not working in some way with some XML files.
Component: Untriaged → Find Toolbar
Product: Firefox → Toolkit
Summary: xml file search doesn't work → Find/search does not work in XML (or XSL) file
Whiteboard: DUPEME?
(Reporter)

Comment 2

6 years ago
any file
http://www.w3schools.com/xml/note.xml
Even on small files "prev" doesn't work.
http://www.w3schools.com/xml/simple.xml
Some time find, some times not. Also highlight all and previous doesn't work.

Comment 3

6 years ago
(In reply to sypachev_s_s@mail.ru from comment #2)
> any file
> http://www.w3schools.com/xml/note.xml
> Even on small files "prev" doesn't work.

bug 263049

> http://www.w3schools.com/xml/simple.xml
> Some time find, some times not. Also highlight all and previous doesn't work.

bug 253261

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449235

Updated

6 years ago
Whiteboard: DUPEME?
You need to log in before you can comment on or make changes to this bug.