Pinned sites should not show "pin site" in context menu

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: ibarlow, Assigned: wesj)

Tracking

20 Branch
Firefox 21
x86
macOS
Points:
---

Firefox Tracking Flags

(firefox20 verified, firefox21 verified)

Details

Attachments

(1 attachment)

Galaxy Nexus running Firefox Aurora 20.0a2 2013-01-15

--

If a site has been pinned, the Pin Site option in the context menu should be replaced by Unpin Site. Currently the menu shows both -- see screenshot http://cl.ly/image/1P2r371K062g
No longer blocks: 817675
Posted patch PatchSplinter Review
Patch
Attachment #703593 - Flags: review?(mark.finkle)
Attachment #703593 - Flags: review?(mark.finkle) → review+
Comment on attachment 703593 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 783312
User impact if declined: Context menu items shown that don't make sense
Testing completed (on m-c, etc.): Landed today
Risk to taking this patch (and alternatives if risky): Very very low risk and simple.
String or UUID changes made by this patch: None. Just hiding strings.
Attachment #703593 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/bc042a2cc38c
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Attachment #703593 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
"Pin Site" option is not displayed anymore for a pinned site on the latest nightly.

Firefox for Android
Version: 21.0a1 (2013-01-23)
Device: Galaxy R
OS: Android 2.3.4
Duplicate of this bug: 828868
Cannot reproduce it on Aurora either. Closing bug as verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.