Closed Bug 830808 Opened 7 years ago Closed 7 years ago

Spike in empty crashes since 17.0.2esr

Categories

(Firefox :: General, defect, critical)

17 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr17 --- affected

People

(Reporter: scoobidiver, Unassigned)

Details

(4 keywords)

Crash Data

Attachments

(1 file)

The empty crash signature accounts for 20% of all crashes in 17.0.1esr but 52% in 17.0.2esr.

The overall crash ratio is 0.5% in 17.0.1esr and 0.8% in 17.0.2esr, i.e. 60% higher. The empty crash ratio is 0.1% in 17.0.1esr and 0.4% in 17.0.2esr, four times higher. So they are really new crashes and not existing crashes that have morphed into this signature.

The Uptime Range breakdown is different between those two versions:
               17.0.2esr       17.0.1esr
 > 1 hour 	28.887 %        53.899 %
15-60 min 	20.239 %        10.092 %
5-15 min 	14.167 %        10.321 %
1-5 min 	18.767 %        19.037 %
< 1 min 	17.939 %         6.651 %

We don't have correlations for ESR versions: https://crash-analysis.mozilla.com/crash_analysis/20130115/

The regression window is:
http://hg.mozilla.org/releases/mozilla-esr17/pushloghtml?fromchange=d8475f8bd98f&tochange=023401f37090

More reports at:
https://crash-stats.mozilla.com/report/list?signature=EMPTY%3A%20no%20crashing%20thread%20identified%3B%20corrupt%20dump&version=Firefox%3A17.0.2esr
https://crash-stats.mozilla.com/report/list?signature=EMPTY%3A%20no%20crashing%20thread%20identified%3B%20corrupt%20dump&version=Firefox%3A17.0.1esr
Almost all are youtube videos in the first query and flash is mentioned:

14 	http://www.facebook.com/
11 	https://www.youtube.com/watch?v=K0lDfenryIQ
11 	about:blank
10 	https://www.facebook.com/
10 	about:newtab
6 	https://www.facebook.com/denisamaria.diaconu
6 	http://www.youtube.com/watch?feature=player_embedded&v=W1U5RUVENNE#!
5 	https://class.coursera.org/crypto-005/lecture/67
5 	http://www.youtube.com/watch?v=AQfDg-0cUF4&feature=player_embedded
5 	http://www.youtube.com/watch?v=LUB5z7GFKa8
5 	http://www.youtube.com/watch?v=m4Th6Z65V-Y
5 	http://www.youtube.com/watch?v=ljkxrOl3Ywg
5 	http://www.youtube.com/watch?v=S8HOPj98kQE
5 	http://www.youtube.com/watch?v=7adqR56dunE
5 	http://www.filmsforaction.org/watch/simply_raw_reversing_diabetes_in_30_days/
5 	http://www.youtube.com/watch?v=6iRH9CafAZA
5 	https://www.youtube.com/watch?v=8Ythoi3A8zY
4 	http://www.youtube.com/watch?v=AEtlmcxGoxE
4 	https://www.youtube.com/watch?v=Ok2369YY2P8
4 	http://www.youtube.com/watch?v=jYSH7suDv8o
4 	http://www.youtube.com/watch?v=Ylq2gnBggCM
4 	http://lourdesderioja.com/2013/01/14/a-consecutive-demo-los-locavoros/
4 	http://www.roligaprylar.se/index.php
4 	http://www.youtube.com/watch?v=6fE3ZpjfkRw
4 	http://www.youtube.com/watch?NR=1&v=_2aNLx9sCEo&feature=endscreen
4 	http://www.youtube.com/watch?v=Pbh82rMRDa0
4 	http://www.youtube.com/watch?v=1D4AyTF-6D8
4 	http://www.youtube.com/watch?v=CYpXI_llRCY
4 	http://www.youtube.com/watch?v=U3eKiJxGIGg
4 	http://www.mozilla.org/en-US/firefox/update/
3 	https://v5.plaympe.com/mpe_player_v5.php
3 	http://www.youtube.com/watch?v=o3mwqsOxQQQ
3 	http://bikeyarou2ch.blog.fc2.com/blog-entry-333.html
3 	https://support.lib.sfu.ca/createuser/AccountPrintout.aspx
3 	https://www.youtube.com/watch?v=7XO6kl1F4II
3 	http://www.youtube.com/watch?v=UJNAIuOT1II
3 	http://www.youtube.com/watch?v=r0yWnWUH6EU
3 	http://www.youtube.com/watch?v=t0ndkqe8eUU
3 	http://www.youtube.com/watch?v=l6A15LjVtWk
3 	http://www.youtube.com/watch?v=3bolSwljLlc
3 	http://www.youtube.com/watch?v=_IKxNva_b_o
3 	http://www.youtube.com/watch?v=ISuDXg2P1hk&feature=endscreen
3 	http://vk.com/im
3 	http://www.youtube.com/watch?v=95GvRH_e38s
3 	http://www.youtube.com/watch?v=bpdNSOOnk_s
3 	http://www.youtube.com/watch?feature=player_embedded&v=Q1jAgxQbTx0
3 	http://www.youtube.com/watch?v=QLsz-KB-bXc
3 	http://video.yandex.ru/#search?text=%D0%BC%D1%83%D0%BB%D1%8C%D1%82%D0%B8%D0%BA%2
3 	http://0680111b.esidoc.fr/rubrique/view/id/16
3 	http://www.youtube.com/watch?v=tynkNOdbDGw
3 	http://www.youtube.com/watch?v=JLnKImsBAZk&feature=endscreen
3 	https://www.youtube.com/watch?v=XkohZWvXhNs
3 	https://www.youtube.com/watch?v=GD5uGLbiA9s
3 	http://www.youtube.com/watch?v=ZxLrKJkbPFY
3 	http://www.youtube.com/watch?feature=player_embedded&v=YfZ9qrwBeeE#!
3 	https://zmail.umd.umich.edu/zimbra/#1
3 	http://www.youtube.com/watch?v=o3p2KZeLHVo
3 	http://www.youtube.com/watch?v=lZGl2GYCQRs
3 	http://www.youtube.com/watch?v=VpHqJh2feOU
3 	http://www.youtube.com/
3 	http://www.youtube.com/watch?v=_ATbbvYgMuQ&noredirect=1
3 	https://www.youtube.com/watch?v=-jAUsWOZuWg&feature=endscreen
3 	http://www.youtube.com/watch?v=QNN9QMrJjGY

Second query in the initial comment:

Total Count 	URL
7 	https://www2.leboncoin.fr/controlpanel?lock=1&m=adqueue&a=show_adqueues&queue=mm
6 	http://www.eltern.de/foren/eltern-raten-eltern-neu/
5 	https://www.facebook.com/
5 	http://clgkochersberg.entea.scolastance.com/sco/Modules/Absences/SuiviAppel.aspx
5 	about:blank
5 	https://www2.leboncoin.fr/controlpanel?lock=1&m=adqueue&a=show_adqueues&queue=ne
5 	https://mail.google.com/mail/u/0/?shva=1#inbox
3 	http://www.troc-velo.com/
3 	http://clgkochersberg.entea.scolastance.com/sco/Modules/Cdt/Saisie.aspx?EventId=
3 	about:newtab
3 	http://www.mpprij.gob.ve/administrator/index.php?option=com_media&view=imagesLis
3 	http://www.leboncoin.fr/annonces/offres/pays_de_la_loire/
3 	http://mnkmspci.medusap.lan:8014/sap/bc/webdynpro/sap/zz_gimedok?sap-client=100&
2 	http://www.finanzen.net/nachricht/Mindspeed-System-on-Chip-SoC-Processors-Drive-
2 	http://www.vario-buero.de/
2 	http://clgkochersberg.entea.scolastance.com/sco/Modules/Messagerie/Webmail.aspx
2 	http://www.rueducommerce.fr/m/pl/malid:52342018
2 	http://clg-joliot-curie-aubiere.entauvergne.fr/sco/Modules/Accueil/Accueil.aspx
2 	http://clgkochersberg.entea.scolastance.com/sco/Modules/Cdt/Saisie.aspx?EventId=
2 	http://172.25.225.32/tamino/K_sola/K01
2 	https://hutch-360dev01.datacenterinc.com/icore360/DEVL07/DCI.Web.Core/DCI.Web.Co
2 	http://www.vadim-schulz.de/
1 	http://hackmemoforme.blog84.fc2.com/page-1.html
1 	http://www.spiegel.de/politik/ausland/algerien-islamisten-nehmen-auslaender-als-
1 	http://www.loireavelo.fr/voir-faire-loire-velo/villes-caractere-velo?gclid=CJzu7
1 	http://www.sfr.fr/mobile/edito/tcommerce/inqChat.html?PRXY
Keywords: needURLs
Based on comment 1, the spike has something to do with Flash.
The fixes related to plugins in the regression range are bug 810082, bug 811375, bug 813906, and bug 819992 and amongst them those with a patch specific to ESR17 are bug 811375 and bug 813906.

It might be caused by a broken CTP Flash blocklisting allowing old versions of Flash to run.
Bug 813906 covers a more exotic case, which shouldn't apply for the listed URLs.
Looking through the patch from bug 811375 i don't see any obvious problems.
A user that hit bug 783369 in 18.0.1, hit this bug in 17.0.2esr (see bug 833216). So I assume it's a duplicate of bug 783369.
(In reply to Scoobidiver from comment #4)
> A user that hit bug 783369 in 18.0.1, hit this bug in 17.0.2esr (see bug
> 833216). So I assume it's a duplicate of bug 783369.

Given the fact that bug 783369 was caused by bug 828296 (FF18-specific), I don't believe it's related.

Anthony - can you attempt to reproduce with some of the URLs in comment 1? I'm seeing a lot of crash comments like "watching html5 video full screen with about 5 tabs open", so we should probably default to HTML5 video on YouTube.
Keywords: qawanted
QA Contact: anthony.s.hughes
Matt, can you please take a look at this?
QA Contact: anthony.s.hughes → mwobensmith
I've been able to crash 17.0.2esr on Win7 64bit twice. Both resulted in a crash with a null signature.

I used the URLs in comment 1 and tried to replicate using info from other comments.

Rough steps below.

1. Go here: http://youtube.com/html5 - opt in to html5 trial
2. Open this: http://www.youtube.com/watch?feature=player_embedded&v=W1U5RUVENNE#!
3. New tab, open this: https://class.coursera.org/crypto-005/lecture/67
4. Mute sound from above video in step 3
5. Open in new tab: http://www.filmsforaction.org/watch/simply_raw_reversing_diabetes_in_30_days/
6. Click on YouTube logo in movie, then open in YouTube
7. Once new tab is opened, click full screen in movie
8. Note slowness
9. Combination of clicking pause/play

Crash.

https://crash-stats.mozilla.com/report/index/bp-6c4e0127-ef15-4d90-b443-5a6132130204
BTW, I just checked and it looks to me like 17.0esr is probably as bad as 17.0.2esr. That said, I have filed bug 837835 on more general investigation of higher empty crash volumes.
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #6)

I can reproduce this crash always on FF 18.0.2 and sometimes on 21.0a1 but on this build it is intermittent (21.a01)
I didn't know if to report a new bug, affraid of beeing duplicate of another existing bug, but if needed I can do this.

Platform: Window 7 x86

STR:
1. Install some addons from top 10 addons
2. Open following URL and make sure all videos are playing

http://www.youtube.com/watch?v=sJuwA5U1qgo
http://www.youtube.com/watch?v=NQ4AZVU8odU
http://www.youtube.com/watch?v=Ct8nZ6eTTiY
http://disneyworld.disney.go.com/new-fantasyland/
http://vimeo.com/47875656
http://www.youtube.com/watch?v=h2qXzMSjVsI
http://edition.cnn.com/video/?hpt=hp_c5#/video/world/2013/02/04/exp-buckingham-palace-knife-man-tasered.cnn
http://www.youtube.com/watch?v=v_UyVmITiYQ
http://www.youtube.com/watch?v=Ct8nZ6eTTiY
http://www.youtube.com/watch?v=NFR-ADakI-c
http://www.youtube.com/watch?v=NQ4AZVU8odU
http://www.miniclip.com/games/en/

3. Open facebook app: http://apps.facebook.com/bejeweledblitz/?fb_source=bookmark_apps&ref=bookmarks&count=0&fb_bmpos=4_0
or http://apps.facebook.com/angrybirdsstarwars/?fb_source=search&fb_appcenter=1#_=_ and play 1-2 rounds while videos from step 2 are playing.
4. Switch some tabs and move forward and back progress bar for videos from step 2. Make theese actions as fast as you can, for each video move progress bar forward and back for a couple o times.
5. It can takes about 10-15 actions to crash. Be patient it will crash.

Here are some of crash reports I received:

https://crash-stats.mozilla.com/report/index/bp-5458f693-8ef9-498e-b22e-544152130204 (about 5 times) (1)
https://crash-stats.mozilla.com/report/index/bp-4a2579c7-8551-4c53-8219-740da2130205
https://crash-stats.mozilla.com/report/list?signature=JSC%3A%3AYarr%3A%3AYarrGenerator%3A%3AopCompileBody%28JSC%3A%3AYarr%3A%3APatternDisjunction*%29

In addition I am using Adobe Flash Player 11 ActiveX and Plugin and Adobe Shockwave Player 11.6

As I can see from Soccoro Top Crashes, https://crash-stats.mozilla.com/topcrasher/byversion/Firefox/21.0a1
(1) is second Top Crash on FF 21.0a1

In step 2 use instead of facebook applications, www.miniclip.com flash games.

I didn't try to reproduce is safe mode, but I guess this is a flash crash, based on my investigations mentioned above.

Removing steps-wanted.
Keywords: steps-wanted
Attached image Memory Usage ScreenShot
Here is my memory usage for Firefox and Flash.

I am using Intel(R) Core(TM) i5-3470 CPU @ 3.40GHz  3.60GHz, 4GB DDR3 1600 MHz.

What is expacted to happen if you have only 2GB Memory if Firefox uses 1GB+ and Flash the same ?

What is weird is that heap-unclassified uses almost 800MB Memory and js-main-runtime almost 300MB
(In reply to MarioMi (:MarioMi) from comment #9)
> (In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #6)

> In step 2 use instead of facebook applications, www.miniclip.com flash games.

Using miniclip flash games I received same crashes as I had received for Facebook applications.
(In reply to MarioMi (:MarioMi) from comment #9) 
> https://crash-stats.mozilla.com/report/index/bp-5458f693-8ef9-498e-b22e-
> 544152130204 (about 5 times) (1)
> https://crash-stats.mozilla.com/report/index/bp-4a2579c7-8551-4c53-8219-
> 740da2130205
There are crashes in 18.0.2 while we are looking for crashes specific to 17.0.2esr. Indeed, the empty signature accounts for 47% of all crashes while only 12% in 18.0.1.

Those STR are more related to bug 837835.
Keywords: steps-wanted
(In reply to Matt Wobensmith from comment #7)
> https://crash-stats.mozilla.com/report/index/bp-6c4e0127-ef15-4d90-b443-
> 5a6132130204

OOMAllocationSize	506880

So this is a straight-up OOM crash.
In the first days of 17.0.3esr, it seems to be back to its previous value, that is 20% of top-300 browser crashes.
It's confirmed that 17.0.3esr has the same ratio of empty crashes than 17.0.1esr, i.e. around 20% of crashes.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
I think it has been fixed by the patch of bug 792274 that was causing bug 834667.
It would be interesting to compare the Telemetry data on memory usage between the previous ESR release and this one, to see if we detected anything.
You need to log in before you can comment on or make changes to this bug.