[FMRadio] FM Radio stops working after an inbound call - reboot required

RESOLVED DUPLICATE of bug 830657

Status

--
critical
RESOLVED DUPLICATE of bug 830657
6 years ago
6 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({unagi})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 702564 [details]
Logcat while testing FM radio

Seen using unagi

Gaia: 688c601f18f2
Gecko: 67503cae6a5a

STR:
1. Begin playing FM radio
2. Dial your unagi device from another phone
3. End the call on the dialing end
4. FM radio will not resume playing

Expected: FM Radio would resume playing
Actual: I Have to reboot the phone to get it to work again.

Logcat attached.

During testing I saw this Gecko message as well: 01-15 15:38:17.015: E/GeckoConsole(109): [JavaScript Error: "FMRadio message DOMFMRadio:getPowerState from a content process with no 'fmradio' privileges." {file: "resource://gre/modules/DOMFMRadioParent.jsm" line: 400}]
Back out this change.
changeset:   118173:00ab761c3545
user:        Philipp von Weitershausen <philipp@weitershausen.de>
date:        Mon Jan 14 19:46:32 2013 -0800
summary:     Bug 823798 - Route FM radio through analog path. r=mwu a=blocking-b2g
and this problem was gone. mark same as 830657.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 830657
blocking-b2g: tef? → ---
QA Contact: jshih → fyen
tracking-b2g18: ? → ---
You need to log in before you can comment on or make changes to this bug.