Closed Bug 831086 Opened 7 years ago Closed 6 years ago

[MP] Defect - When in filled or snapped view, Metro Firefox appears squished and has a large black column of unused space

Categories

(Firefox for Metro Graveyard :: Browser, defect, P1)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 27

People

(Reporter: TimAbraldes, Assigned: bbondy)

References

Details

(Whiteboard: [preview] feature=defect c=Browser_views u=metro_firefox_user p=3)

Attachments

(5 files)

No description provided.
No longer blocks: 801000
Depends on: 801000
No longer depends on: 801000
No longer blocks: 830505
Duplicate of this bug: 860221
p=2 if it's still reproducible.
I'm not able to reproduce this issue since I switched to a new machine, but others (see bug 860221) have been able to reproduce recently
Duplicate of this bug: 865574
Blocks: metrov1defect&change, 831896
No longer blocks: metrov1triage
Summary: When in filled or snapped view, Metro Firefox appears squished and has a large black column of unused space → Defect - When in filled or snapped view, Metro Firefox appears squished and has a large black column of unused space
Whiteboard: feature=defect c=Browser_views u=metro_firefox_user p=0
Blocks: metrov1it7
No longer blocks: metrov1defect&change
Whiteboard: feature=defect c=Browser_views u=metro_firefox_user p=0 → feature=defect c=Browser_views u=metro_firefox_user p=2
Priority: -- → P1
Assignee: nobody → sfoster
QA Contact: jbecerra
Status: NEW → ASSIGNED
I can't reproduce this either. I tried changing the display setting "Size of all items" to 100%, 125%, 150% and 200% to get a range of screen densities. I see no squishing or black gap in filled or snapped view I'm afraid.
Assignee: sfoster → nobody
Status: ASSIGNED → NEW
Would anyone else like to try to reproduce this bug?  If we can't, we can mark it as 'works for me' for now.
(In reply to Marco Mucci [:MarcoM] from comment #8)
> Would anyone else like to try to reproduce this bug?  If we can't, we can
> mark it as 'works for me' for now.

I ran into this issue about a week ago and created Bug 865574 (a duplicate of this one). I can reproduce the issue consistently on my main desktop machine. The only thing that changed would be a few Windows 8 updates but that's pretty much it (haven't installed any new nvidia drivers or anything relating to display that could be causing this issue)
Thanks Kamil.  I'll move this Defect out of the Iteration for now.  It can be assigned again for development at any time.
Blocks: metrov1defect&change
No longer blocks: metrov1it7
Whiteboard: feature=defect c=Browser_views u=metro_firefox_user p=2 → feature=defect c=Browser_views u=metro_firefox_user p=0
Kamil if you can still reproduce this, can you go to about:support and paste in the section from the Graphics section?
Flags: needinfo?(kamiljoz)
Brian, I can reproduce it every single time on my main machine. I've attached the Graphic information from about:support as a text file. Also attached a screenshot that shows the issue that I am receiving on this machine. (main desktop)
Flags: needinfo?(kamiljoz)
Thanks!
Nothing unusual about the gfx info Kamil attached, I'll likely have to find hardware or a VM that reproduces this to fix.
Whiteboard: feature=defect c=Browser_views u=metro_firefox_user p=0 → [shovel-ready if repro] feature=defect c=Browser_views u=metro_firefox_user p=0
Just a quick update, installed the latest nvidia drivers that have been released (320.18) about 2 weeks ago and ran into the same issue. Get these distortions using both "Filled" & "Snapped" views.
I'm new here and I can reproduce this on my machine always. I'd like to take a shot at this. Brian (or anyone willing) can you point out to me where I start with fixing this and how to write tests? Thanks.
Flags: needinfo?(netzen)
Hey Mina, I'm not sure if you were hoping more for a Javascript bug or not, I suspect this is a C++ problem.  In case you're still interested I'd start looking here:
http://dxr.mozilla.org/mozilla-central/source/gfx/layers/d3d10/LayerManagerD3D10.cpp#l648

In particular I'd look for errors when resizing or the wrong values being passed there.
Flags: needinfo?(netzen)
Duplicate of this bug: 888342
Blocks: 877225
Whiteboard: [shovel-ready if repro] feature=defect c=Browser_views u=metro_firefox_user p=0 → feature=defect c=Browser_views u=metro_firefox_user p=0 [shovel-ready if repro]
Duplicate of this bug: 896667
Whiteboard: feature=defect c=Browser_views u=metro_firefox_user p=0 [shovel-ready if repro] → feature=defect c=Browser_views u=metro_firefox_user p=0 [shovel-ready if repro][preview-triage]
Whiteboard: feature=defect c=Browser_views u=metro_firefox_user p=0 [shovel-ready if repro][preview-triage] → [preview-triage] [shovel-ready if repro] feature=defect c=Browser_views u=metro_firefox_user p=0
Blocks: metrov1backlog
No longer blocks: metrov1defect&change
Is anyone still seeing this? some patches landed recently that may have addressed the issue (bug 899435).
Summary: Defect - When in filled or snapped view, Metro Firefox appears squished and has a large black column of unused space → [MP] Defect - When in filled or snapped view, Metro Firefox appears squished and has a large black column of unused space
Whiteboard: [preview-triage] [shovel-ready if repro] feature=defect c=Browser_views u=metro_firefox_user p=0 → [preview] [shovel-ready] feature=defect c=Browser_views u=metro_firefox_user p=0
Still happening on my main Desktop machine, downloaded the latest build from the following location:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-08-13-03-02-05-mozilla-central/

Let me know if you would like another screenshot, but the issue is basically the same as all the other screenshots attached above. It only works correctly when Metro is in full view, as soon as you use any other view you will run into the issue
Have we figured out what the underlying issue even is?
Whiteboard: [preview] [shovel-ready] feature=defect c=Browser_views u=metro_firefox_user p=0 → [preview] feature=defect c=Browser_views u=metro_firefox_user p=0
No, but if someone can fedex me hardware that can reproduce, I'm pretty sure I can fix it. Asa/Juan/Marco? Will ship back after fixing.
Hey Brian, I have the laptop kats used - would that work for you?  If so, I can ship it out to you.
Hey Marco, Can you reproduce the original issue with this bug? See the screenshots above. It would be awesome if so, and yes I'd like it.  But if you can't reproduce with it, then there is no benefit to send it.
Flags: needinfo?(mmucci)
I will look across all of my machines today and try to reproduce.
No longer blocks: 877225
Tested on 2013-09-16. I haven't been able to reproduce this using the latest nightly on my Dell XPS 12 nor my Iconia W3.
I could not reproduce this bug from the build downloaded here:

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013/08/2013-08-13-03-02-05-mozilla-central/firefox-26.0a1.en-US.win64-x86_64.installer.exe

or from the latest build on nightly.mozilla.org

using a Sony Vaio Duo 11
Hey Brian.  Marina was not able to reproduce it on a new device in Toronto.  Going to double check with Juan and Asa to see if they can.
Flags: needinfo?(mmucci)
Hey Juan, can you reproduce this on one of your devices.  If so, I'd like to have that device shipped to Brian temporarily to fix it and then it can be returned to you.
Flags: needinfo?(jbecerra)
I haven't been able to reproduce this on the couple of devices I had access to today.
Flags: needinfo?(jbecerra)
Thanks for the update Juan.  

Asa, your our last hope. :)
Flags: needinfo?(asa)
I can still reproduce this problem on my desktop machine 100% of the time. I will setup the machine with VS and the required checked out code.

I'll get Brian remote access so he can take a look at the machine and hopefully debug this problem!
Blocks: metrov1it15
No longer blocks: metrov1backlog
Clearing needinfo because Kamil got me remote access.
Assignee: nobody → netzen
Status: NEW → ASSIGNED
Flags: needinfo?(asa)
Attached patch Patch v1Splinter Review
Verified this fixed the problem on the Optimus machine. 
Basically we want to resize 2 buffers if we're running immersive firefox and not 1.  We want the metro specific handling to override the optimus specific handling.
Attachment #806012 - Flags: review?(bas)
Whiteboard: [preview] feature=defect c=Browser_views u=metro_firefox_user p=0 → [preview] feature=defect c=Browser_views u=metro_firefox_user p=3
Comment on attachment 806012 [details] [diff] [review]
Patch v1

Review of attachment 806012 [details] [diff] [review]:
-----------------------------------------------------------------

This is correct.
Attachment #806012 - Flags: review?(bas) → review+
https://hg.mozilla.org/mozilla-central/rev/52c6d7c21e78
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

Verified during iteration 15 testing and WFM on latest nightly (build ID: 20130930030205).

The Metro Firefox appears without any UI issues while using both filled and snapped view, it does not appear squished and hasn't any unused space.
Marking as verified.

If someone else is still able to reproduce this, please file a new bug or reopen this issue.
Status: RESOLVED → VERIFIED
I will also take a look and try it on the machine that I was originally having the issues with when I get home first thing tonight.
Went through this defect for iteration #15 testing and it generally works pretty well! Most the issues that where occurring on this desktop machines when it came to views have been resolved. Ran into a few more issues but not sure if they are related to the following defect. Created Bug 922456
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.