messenger.xul: ReferenceError: gDisallow_classes_no_html is not defined

RESOLVED FIXED in seamonkey2.18

Status

SeaMonkey
MailNews: General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

Trunk
seamonkey2.18

SeaMonkey Tracking Flags

(seamonkey2.15 fixed, seamonkey2.16 fixed, seamonkey2.17 fixed, seamonkey2.18 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
While investigating Bug 831249 I ran into these errors:

Thu Jan 17 2013 00:19:17
Error: ReferenceError: gDisallow_classes_no_html is not defined
Source file: chrome://messenger/content/messenger.xul
Line: 1

Fallout from bug 438429: meta bug to fix several RSS Summary/Web Page bugs.

Suite uses disallow_classes_no_html instead of gDisallow_classes_no_html

Also:

Thu Jan 17 2013 00:40:35
Error: TypeError: this.browsers[i] is undefined
Source file: chrome://navigator/content/tabbrowser.xml
Line: 1077
(Assignee)

Comment 1

4 years ago
Created attachment 702865 [details] [diff] [review]
Patch 1.0 Fix it.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #702865 - Flags: superreview?(mnyromyr)
Attachment #702865 - Flags: review?(iann_bugzilla)

Updated

4 years ago
Attachment #702865 - Flags: superreview?(mnyromyr)
Attachment #702865 - Flags: superreview+
Attachment #702865 - Flags: review?(iann_bugzilla)
Attachment #702865 - Flags: review+
(Assignee)

Comment 2

4 years ago
Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/9876dc5fd507
Target Milestone: --- → seamonkey2.18
(Assignee)

Comment 3

4 years ago
Comment on attachment 702865 [details] [diff] [review]
Patch 1.0 Fix it.

[Approval Request Comment]
Regression caused by (bug #): Bug 438429
User impact if declined: View-> (Feed) Message Body as... will show all six menu items (both mail/news items and Feed items)
Testing completed (on m-c, etc.): comm-central
Risk to taking this patch (and alternatives if risky): low risk bustage fix.
String changes made by this patch: None.

Note no one complained about this since Bug 438429 landed (SeaMonkey 2.0) so priority is low/ nice to have but not a blocker.
Attachment #702865 - Flags: approval-comm-release?
Attachment #702865 - Flags: approval-comm-beta?
Attachment #702865 - Flags: approval-comm-aurora?
(In reply to Philip Chee from comment #0)
> Also:
> 
> Thu Jan 17 2013 00:40:35
> Error: TypeError: this.browsers[i] is undefined
> Source file: chrome://navigator/content/tabbrowser.xml
> Line: 1077

Bug 638915. Still.

(In reply to Philip Chee from comment #3)
> User impact if declined: View-> (Feed) Message Body as... will show all six
> menu items (both mail/news items and Feed items)

I cannot seem to reproduce this. Can you expand on the STR?
(Assignee)

Comment 5

4 years ago
> I cannot seem to reproduce this. Can you expand on the STR?
Err, now that I've got the patch applied locally I don't have a STR ;P

Updated

4 years ago
Attachment #702865 - Flags: approval-comm-release?
Attachment #702865 - Flags: approval-comm-release+
Attachment #702865 - Flags: approval-comm-beta?
Attachment #702865 - Flags: approval-comm-beta+
Attachment #702865 - Flags: approval-comm-aurora?
Attachment #702865 - Flags: approval-comm-aurora+
(Assignee)

Comment 6

4 years ago
Pushed to all branches:
http://hg.mozilla.org/releases/comm-aurora/rev/0bdf9bee7863
http://hg.mozilla.org/releases/comm-beta/rev/921f220f5956
http://hg.mozilla.org/releases/comm-release/rev/77eb2bc81830
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-seamonkey2.15: --- → fixed
status-seamonkey2.16: --- → fixed
status-seamonkey2.17: --- → fixed
status-seamonkey2.18: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.