Closed Bug 831960 Opened 7 years ago Closed 7 years ago

Story - Clear my Metro Firefox History

Categories

(Tracking Graveyard :: Metro Operations, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 845484

People

(Reporter: asa, Unassigned)

References

Details

Attachments

(2 files)

No description provided.
Priority: -- → P2
Whiteboard: c=Settings_pane_options_and_about u= p= → c=Settings_pane_options_and_about u=metro_firefox_user p=
Whiteboard: c=Settings_pane_options_and_about u=metro_firefox_user p= → c=Settings_pane_options_and_about u=metro_firefox_user p=2
Summary: Clear my Metro Firefox History → Story - Clear my Metro Firefox History
Whiteboard: c=Settings_pane_options_and_about u=metro_firefox_user p=2 → c=Settings_pane_options_and_about u=metro_firefox_user p=2 feature=story
OS: Windows 8 → Windows 8 Metro
Whiteboard: c=Settings_pane_options_and_about u=metro_firefox_user p=2 feature=story → feature=story c=Settings_pane_options_and_about u=metro_firefox_user p=0
Depends on: 831520
Whiteboard: feature=story c=Settings_pane_options_and_about u=metro_firefox_user p=0 → feature=story c=Settings_pane_options_and_about u=metro_firefox_user p=2
Assignee: nobody → netzen
Status: NEW → ASSIGNED
Based on the suggestion of Matt, I agree "Clear Private Data" is clearer than "Clear History".

And we need a description of this option:
"This will clear your browsing history, passwords, cookies, site permissions, and form data on this device"

I will update the options flyout mockup.
Blocks: metrov1it2
No longer blocks: metrov1backlog
Yuan is there a bug that's needed to be added blocking this story based on the second part of comment 1? Or will that be blocking a different bug?  If it's for this story could you provide a new mockup?
Flags: needinfo?(ywang)
Attached image [Mockup] Options_v6
I updated the options mockup (yes, again).
Brian, you can find  the "Clear Private Data" section and its different state on the mockup.

Changes on this version:
1. Changed the order of options to keep consistent with Android:
General, Content, Privacy&Security, Import

2. Updated the wording on Tracking. Keep it consistent with desktop and android. (Note: According to Larissa Co, Do No Track might change from a switch to a drop-down menu with 3 exclusive options in the future.)

3. Removed redundant description of "Remember passwords".

4. Simplified the description of "Clear Private Data", to fit in 2 rows.

5. Added a disable state for actions buttons. When the clearing/importing process is complete, action button should be disabled. 

6. Changed the color of progress spinner to black color. (Based on the guideline for indeterminate progress control, the color of spinner should be the same with texts.)

A lot of the UI I mentioned above have not been implemented to nightly yet. I assume in this case, we don't need to submit bugs to make official changes.
Flags: needinfo?(ywang)
Blocks: metrov1backlog
No longer blocks: metrov1it2
Duplicate of this bug: 801007
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---
Assignee: netzen → nobody
Whiteboard: feature=story c=Settings_pane_options_and_about u=metro_firefox_user p=2 → feature=story c=Settings_pane_options_and_about u=metro_firefox_user p=5
This has been folded into bug 845484.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 845484
Whiteboard: feature=story c=Settings_pane_options_and_about u=metro_firefox_user p=5 → feature=story c=Settings_pane_options_and_about u=metro_firefox_user p=0
No longer blocks: metrov1backlog, 831558
Whiteboard: feature=story c=Settings_pane_options_and_about u=metro_firefox_user p=0
OS: Windows 8 Metro → Windows 8.1
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.