Closed Bug 831976 Opened 7 years ago Closed 7 years ago

Story - Fluff out Click Targets for Touch and Restore for Pointer

Categories

(Tracking Graveyard :: Metro Operations, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: asa, Assigned: mbrubeck)

References

Details

(Whiteboard: feature=story status=for_sprint c=Content_features u=metro_firefox_user p=8)

Attachments

(2 files)

No description provided.
Priority: -- → P2
Whiteboard: c=Content_features u= p= → c=Content_features u=metro_firefox_user p=
Whiteboard: c=Content_features u=metro_firefox_user p= → c=Content_features u=metro_firefox_user p=8
Assignee: nobody → mbrubeck
Depends on: 788109
Depends on: 832101
OS: Windows 8 → Windows 8 Metro
Summary: fluff out click targets for touch and restore for pointer → Story - Fluff out Click Targets for Touch and Restore for Pointer
Whiteboard: c=Content_features u=metro_firefox_user p=8 → feature=story status=for_sprint c=Content_features u=metro_firefox_user p=8
Status: NEW → ASSIGNED
The work for this story landed on elm this morning, so it will be included in the next nightly build.

QA note: For verifying this story, you might want to set ui.mouse.radius.topmm and ui.mouse.radius.botommm to a larger value, like 20.  This should let you "click" a link by tapping up to 2cm above or below it (but only with touch, not mouse).
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Blocks: metrov1it1
Whiteboard: feature=story status=for_sprint c=Content_features u=metro_firefox_user p=8 → feature=story status=for_sprint c=Content_features u=metro_firefox_user p=0 status=for_testing
Whiteboard: feature=story status=for_sprint c=Content_features u=metro_firefox_user p=0 status=for_testing → feature=story status=for_sprint c=Content_features u=metro_firefox_user p=0
Whiteboard: feature=story status=for_sprint c=Content_features u=metro_firefox_user p=0 → feature=story status=for_sprint c=Content_features u=metro_firefox_user p=8
No longer blocks: metrov1backlog
Depends on: 837242
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---
Depends on: 859629
Found a "Defect" that is related to the following story when going through it4 testing. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-04-08-03-09-28-mozilla-central/

Also went through the following test cases:

- Disabled "ui.mouse.radius.enabled" and ensured it was disabled without any issues. Made sure that both touch and mouse worked as expected
- Changed "ui.mouse.radius.topmm" and "ui.mouse.radius.bottommm" to 20 and tested on several sites as described in Comment 1

Another problem that I ran into that is described in Bug 788109 (Dependency) is the issues with metafilter.com and links not being selected when tapping near them.

- Attached the "Defect" to this ticket
Re-verified for it#7, went through steps on Comment 3 and it's all working expect for bug 859629.
Went through the following "Defect" for iteration #8 testing with some issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-16-03-11-39-mozilla-central/

- Went through the test cases outlined in comment 3 without any issues

Notes:

- Click target fluffing still doesn't work on certain websites such as Facebook, metafilter.com, polygon.com, drupal.org (Bug 859629)
Went through the following "Defect" for iteration #9 testing with some issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-07-03-03-13-23-mozilla-central/

- Went through the original story that has been attached without any issues
- Went through the test cases added in comment 3 without any issues
- Enabled/Disabled "ui.mouse.radius.enabled" and ensured both taps and clicks worked without any issues

Notes:

- Click target fluffing still doesn't work on certain websites such as Facebook, metafilter.com, polygon.com, drupal.org (Bug 859629)
WFM.

Tested on Windows 8.1 preview for iteration 10 using latest nightly from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-22-03-02-26-mozilla-central/

I followed user story and got expected result.
Depends on: 901036
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130808030205
Built from http://hg.mozilla.org/mozilla-central/rev/fd4cf30428b0

WFM
Tested on windows 8 using latest nightly for iteration-11. Followed steps provided in user story and got expected result.
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130823030204
Built from http://hg.mozilla.org/mozilla-central/rev/fb2318875cd4

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in user story and got expected result.
Status: RESOLVED → VERIFIED
Went through the following "Story" for iteration #13 testing with the same issues as before. Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-08-31-03-02-24-mozilla-central/

Fluffing still doesn't work on certain websites. Bug 859629 is tracking that issue. I also commented in that bug that the issue is still occurring.

- Went through the original story as per comment #0
- Went through the test cases that have been added in comment #6
- Went through all of the above issues using filled view
OS: Windows 8 Metro → Windows 8.1
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.