Work - Enable 'ui.touch.radius' and remove metrofx specific front end code

RESOLVED FIXED

Status

Firefox for Metro
Input
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: jimm, Assigned: mbrubeck)

Tracking

Trunk
All
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [metro-mvp][LOE:1][metro-it2][completed-elm][feature=work])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
See bug 780847 and ElementTouchHelper in

http://mxr.mozilla.org/projects-central/source/elm/browser/metro/base/content/contenthandlers/Content.js#49
(Assignee)

Updated

5 years ago
Assignee: nobody → mbrubeck
(Reporter)

Updated

5 years ago
Component: General → General
Product: Firefox → Firefox for Metro
(Assignee)

Comment 1

5 years ago
Bug 794621 seems to have broken our front-end click redirection code.  Enabling the platform support should fix that regression.  Unfortunately it doesn't seem to be as simple as toggling the pref; when I do that, clicking near a link seems to focus/highlight it, but doesn't actually click it.
Blocks: 794621
Component: General → Input
Hardware: x86_64 → All
Whiteboard: [metro-mvp][LOE:1][metro-it2]
(Assignee)

Comment 2

5 years ago
Actually the preference works fine on most sites, but doesn't work for some reason on http://www.metafilter.com/ which I happened to be using for testing.  Weird!  MetaFilter must be hitting some sort of bug or corner case in the platform code.
(Assignee)

Comment 3

5 years ago
Created attachment 689436 [details] [diff] [review]
patch

I had to keep our "getClosest" method for now because it's used for tap highlighting, but I changed it to use the same prefs as the platform code.  I'll file a separate follow-up bug to move the tap highlighting into platform.
Attachment #689436 - Flags: review?(jmathies)
(Reporter)

Comment 4

5 years ago
Comment on attachment 689436 [details] [diff] [review]
patch

I clicked around on various sites, didn't seem much of a difference in behavior.

FWIW, I'm not a fan of our current highlight behavior anyway. Seems like the aesthetics need work. Usually the highlight is a semi-transparent dark blue rectangular block along the span of text, which looks kinda ugly. Honestly I'd prefer we just turn the highlight off to see how things work without it.
Attachment #689436 - Flags: review?(jmathies) → review+
(Reporter)

Comment 5

5 years ago
I'm tempted to to file a bug in dom along the lines of "Improve aesthetics of 'active' state for links for mobile platforms". What do you think Matt?
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/projects/elm/rev/6506c6476906
Status: NEW → ASSIGNED
Whiteboard: [metro-mvp][LOE:1][metro-it2] → [metro-mvp][LOE:1][metro-it2][completed-elm]
(Assignee)

Comment 7

5 years ago
(In reply to Jim Mathies [:jimm] from comment #5)
> I'm tempted to to file a bug in dom along the lines of "Improve aesthetics
> of 'active' state for links for mobile platforms". What do you think Matt?

Yes, please do!
(Reporter)

Comment 8

5 years ago
Created attachment 700586 [details] [diff] [review]
follow up
Attachment #700586 - Flags: review?(mbrubeck)
(Assignee)

Updated

5 years ago
Attachment #700586 - Flags: review?(mbrubeck) → review+
(Reporter)

Comment 9

5 years ago
https://hg.mozilla.org/projects/elm/rev/7526b43519aa
(Assignee)

Updated

5 years ago
Blocks: 831976

Updated

5 years ago
Summary: Enable 'ui.touch.radius' and remove metrofx specific front end code → Work - Enable 'ui.touch.radius' and remove metrofx specific front end code
Whiteboard: [metro-mvp][LOE:1][metro-it2][completed-elm] → feature=work
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: feature=work → [metro-mvp][LOE:1][metro-it2][completed-elm][feature=work]
(Assignee)

Updated

5 years ago
Depends on: 835175
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.