offline: is the download messages prompt supposed to appear in a new/reply/forward message when you toggle the indicator?

VERIFIED FIXED in mozilla0.9.4

Status

SeaMonkey
MailNews: Backend
P3
normal
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: grylchan, Assigned: Bienvenu)

Tracking

Trunk
mozilla0.9.4
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
testing commercial builds
 2001052904 on Win NT 4.0
 2001052908 on Linux 2.2
 2001052908 on MAC OS 9.0.4

If you are online and you do one of the following:
 -a new message composition
 -a reply to a message
 -forward a message

And in the 'composition' message window, you click the offline
widget, Are you supposed to be prompted with "do you want to
download messages for offline use" gui or not?

You are prompted if you bring up a seperate 'read' mail/news message window
and you click the offline widget.

Again not sure what the behavior is. 4.x didn't have the prompt
when going offline do you want to download messages.

Comment 1

17 years ago
My thought is that using either the online/offline menu items OR the 
online/offline icon in any of the windows to go online or offline would obey the 
user's preferences for whether they want to be prompted or not.

I belief 4.x only obeyed the user's prefs for whether to be prompted when going 
online or offline when using the menu item only and not when using the 
online/offline icons in any of the windows.

Do folks have thoughts or a prefence for which behavior to go with?
(Assignee)

Comment 2

17 years ago
I like the way 4.x worked because I use the icon for a quick, minimal
online<->offline transition, and if I want the the full-on sync stuff, I would
use the menu item. But that's just my preference. CC'ing Seth - I think he might
know why the compose window offline widget doesn't work like the others.
gchan,

I made it so the only place you'd get prompted is when you toggle the offline
state (via the menu or the icon) in the 3 pane or stand alone msg window.

in all other windows [compose, navigator, editor], the menu item or the icon
will not prompt you.  [note, there are some windows where we have the offline
icon but it is broken, known bug]

jglick:  can you add a note to the spec describing what you want and add a link
to it here?  no big rush, since I think we can live with the current behaviour
for a while.  

but before I go change things, I'd like a spec to follow.
(Assignee)

Comment 4

17 years ago
Can we resolve this as invalid or wontfix? Or have we decided to do something
different from the current behaviour?
(Assignee)

Comment 5

17 years ago
OK, enough people are complaining about this. I think we should make it so that
we always prompt the user, if that's there preference, at least in the message
compose window, if not the browser window. Is it hard to add this to the compose
window, Seth?
Status: NEW → ASSIGNED
(Assignee)

Comment 6

17 years ago
*** Bug 91841 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

17 years ago
OK, I've got this working. I had to move a bunch of offline js code into a new
file (mail-offline.js) and tweak the compose ui to have a var msgWindow so the
offline js code would work. I'll start attaching patches.
(Assignee)

Comment 8

17 years ago
Created attachment 43669 [details] [diff] [review]
new offline js file

Comment 9

17 years ago
adding nsenterprise keyword
Keywords: nsenterprise
(Assignee)

Comment 10

17 years ago
Created attachment 44234 [details] [diff] [review]
base/resources part of fix
(Assignee)

Comment 11

17 years ago
Created attachment 44235 [details] [diff] [review]
compose diffs for fix
(Assignee)

Comment 12

17 years ago
Created attachment 44236 [details] [diff] [review]
diffs for jar.mn
(Assignee)

Comment 13

17 years ago
Can I get review from JF and an sr from Seth, please? Diane and Mohan, I want to
point out again that I will be moving a bunch of your offline js stuff into this
new file, mail-offline.js, so if you need to change those routines, they're now
in a new file. This will be better for you in the long run, since you will be
much less likely to get any conflicts.

Comment 14

17 years ago
adding nsenterprise+
Keywords: nsenterprise → nsenterprise+
Priority: -- → P3
Target Milestone: --- → mozilla0.9.4
R=ducarroz for the last 4 patches. BTW, you don't really need anymore to declare
the offline js file into make or MANIFEST files are we are now using only the
jar.mn file.
sr=sspitzer

since you're mostly moving code around.

ducarroz is right about the MANIFEST and makefile.win changes, they are not needed.

Summary: offline: is the download messages prompt supposed to appear in a new/reply/forw message when you toggle the indicator? → offline: is the download messages prompt supposed to appear in a new/reply/forward message when you toggle the indicator?
(Assignee)

Comment 17

17 years ago
fix checked in - diane and mohanb, please note that the offline js routines have
now moved to mail-offline.js
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

17 years ago
Commercial builds:
2001-08-15-09-trunk/ - nt 4.0
2001-08-15-14-trunk- linux 2.2, mac 9.0.4

Verified the following (both themes):
 For mail and newsgroups
  -reg stand alone mesg, compose, reply, reply all, forward,  
   message windows had the prompt "do you want to download mesgs" if you
   clicked on the icon or went through the file menu (only a stand alone
   message can you go offline through the file menu)
Marking as verified

Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.