Closed Bug 832163 Opened 8 years ago Closed 8 years ago

Add a command for toggling the debugger server on desktop

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: vporof, Assigned: jwalker)

References

Details

Attachments

(1 file)

See https://bugzilla.mozilla.org/show_bug.cgi?id=751677#c5:

"For desktop vs. desktop debugging sessions, some UI for starting a server is also needed. Ninjas currently rely on running bits of code found in various mythical gists, which is less than optimal."
maybe a gcli command? This is a pretty niche feature for, as you say, ninjas.
Component: Developer Tools: Debugger → Developer Tools: Graphic Commandline and Toolbar
moving back to debugger based on Panos' feelings that Joe would like commands to live in their respective components. Sheesh!
Component: Developer Tools: Graphic Commandline and Toolbar → Developer Tools: Debugger
Priority: -- → P3
Joe showed us something along these lines earlier today, so I guess it's his bug now!
Assignee: nobody → jwalker
Status: NEW → ASSIGNED
This is needed for our styleeditor work as well
Can the UI sit in the new options panel that is coming up in bug 851546 ?
If this lands first, I can import it in the Connect tab of the options panel, sitting just next to the connect screen. Once the user starts the debugger, we can also tell him the port and host on which the server is running.

It would be even simpler (to port to options panel) to do this if the UI for starting debugger server sits in the connect screen itself. We can have something like:


 _____________________________________________________________________________
|                                                                             |
|                                   |                                         |
|  Connect to remote device         |    Start the debugger on this machine   |
|            -------------          |    so that remote clients can connect   |
|    Host : |             |         |                                         |
|            -------------          |                                         |
|            -------------         or        --------------                   |
|    Port : |             |         |       | Start Server |                  |
|            -------------          |        --------------                   |
|            ---------              |                                         |
|           | Connect |             |                                         |
|            ---------              |                                         |
|                                   |                                         |
|_____________________________________________________________________________|
I like Optimizer's idea. But a simple command could be a good first step.

> listen 6000
(In reply to Paul Rouget [:paul] from comment #6)
> I like Optimizer's idea.

Me too.
(In reply to Panos Astithas [:past] from comment #7)
> (In reply to Paul Rouget [:paul] from comment #6)
> > I like Optimizer's idea.
> 
> Me too.

Lets discuss the options dialog in it's bug, and leave this bug for the command.
OK?
(In reply to Joe Walker [:jwalker] from comment #8)

> Lets discuss the options dialog in it's bug, and leave this bug for the
> command.
> OK?

Specializing the subject accordingly.
Summary: Add UI for toggling the debugger server on desktop → Add a command for toggling the debugger server on desktop
Bug 839862 contains a 'listen' command.
Depends on: 839862
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 821032
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.