Closed Bug 751677 Opened 9 years ago Closed 8 years ago

Rethink the UI bits for the remote debugging case

Categories

(DevTools :: Debugger, defect, P3)

12 Branch
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: vporof, Unassigned)

References

Details

Followup for bug 748927.
Besides the obvious stuff, we really need an activity indicator, because connections could take a while. Especially when they timeout.
add more throbber?
(In reply to Victor Porof from comment #1)
> Besides the obvious stuff, we really need an activity indicator, because
> connections could take a while. Especially when they timeout.

By obvious stuff, maybe think of something else than a popup.
Priority: -- → P3
As we discussed with shorlander and paul, the eventual UI for launching remote and chrome debugging should be buttons in the debugger UI and not menu items. That's the main thing for this bug in addition to the activity indicator. A prompt (of some sort) for getting the remote connection endpoint was deemed sufficient, so no need to touch that part for now, I guess.
Note: for desktop vs. desktop debugging sessions, some UI for starting a server is also needed. Ninjas currently rely on running bits of code found in various mythical gists, which is less than optimal.
Duplicate of this bug: 800442
Related bug: bug 802231. Also, we now need to provide an implementation that can be used by all of our remotable tools.
<past> We also need to add a target dialog to the chrome debugger so that one can direct it to fennec (or thunderbird in the future)
Looks to me like this bug has been fixed by the Connect screen, apart from the scenario described in comment #5. Filed bug 832163 for that.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.