Phones should use Android spinners

RESOLVED FIXED in Firefox 20

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: sriram, Assigned: sriram)

Tracking

unspecified
Firefox 21
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 fixed, firefox21 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

To have a UI that's simple (without Android's tabs) and scalable from a l10n perspective, it's better to use Spinners everywhere.
This uses spinners on phones. On GB phones, this is emulated as a Button + PopupMenu.
Attachment #704016 - Flags: review?(mark.finkle)
Posted patch Part 2: Remove tabs widget (obsolete) — Splinter Review
This removes the Android Tabs widget completely. Phew.
Attachment #704017 - Flags: review?(mark.finkle)
Blocks: 817675
This removes a redundant file on top of the previous patch.
Attachment #704017 - Attachment is obsolete: true
Attachment #704017 - Flags: review?(mark.finkle)
Attachment #704021 - Flags: review?(mark.finkle)
Attachment #704016 - Flags: review?(mark.finkle) → review+
Comment on attachment 704021 [details] [diff] [review]
Part 2: Remove tabs widget

Nice! I feel better already with TabWidget gone.
Attachment #704021 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/4d919195cdf0
https://hg.mozilla.org/mozilla-central/rev/ea6e7fbcd3a5
Assignee: nobody → sriram
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 704016 [details] [diff] [review]
Part 1: Use spinners on phones

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature
User impact if declined: We show android style tabs on phones -- instead of spinners.
Testing completed (on m-c, etc.): Landed in m-c on 01/19
Risk to taking this patch (and alternatives if risky): Very low.
String or UUID changes made by this patch: None.
Attachment #704016 - Flags: approval-mozilla-aurora?
Comment on attachment 704021 [details] [diff] [review]
Part 2: Remove tabs widget

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature
User impact if declined: We show android style tabs on phones -- instead of spinners.
Testing completed (on m-c, etc.): Landed in m-c on 01/19
Risk to taking this patch (and alternatives if risky): Very low.
String or UUID changes made by this patch: None.
Attachment #704021 - Flags: approval-mozilla-aurora?
Any reason this needs to skip the trains?  Seems like we'd be wise to let it ride the trains and keep an eye out for any regressions from such an overhaul.
This is needed for the new Tabs UI changes in bug 817675. Most other patches that are needed have been uplifted.

(Note: This feature might even change as the UX is making calls on the UI still. But, to avoid problems in Aurora by missing a patch inbetween, I would like to uplift it and keep it in same state as m-c).
The new design doesn't use spinners. We might not need to uplift this to Aurora. I could post a patch thats Aurora-ready (but I am not sure of the possible regressions as it would be double the work) or, we could uplift this and take the patch from m-c to be on top of this.
Comment on attachment 704016 [details] [diff] [review]
Part 1: Use spinners on phones

Approving for Aurora but expecting that qa/mobile devs will keep an eye out for potential regressions once this gets to Beta and has more users.
Attachment #704016 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #704021 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.