Closed Bug 832457 Opened 7 years ago Closed Last year

"Thunderbird failed to find the settings for your email account" [autoconfig]

Categories

(Thunderbird :: Account Manager, defect)

24 Branch
x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 647761

People

(Reporter: mozilla_bugzilla, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151925

Steps to reproduce:

I tried to configure my email account.




Actual results:

Auto-detection did not work. I then entered everything manually and got the following error message: Thunderbird failed to find the settings for your email account


Expected results:

Thunderbird should have configured my email account


Below is the log on the server:

Jan 18 21:36:31 hebus postfix/smtpd[2173]: connect from unknown[192.168.173.254]
Jan 18 21:36:31 hebus postfix/smtpd[2173]: improper command pipelining after EHLO from unknown[192.168.173.254]: QUIT\r\n
Jan 18 21:36:31 hebus postfix/smtpd[2174]: connect from unknown[192.168.173.254]
Jan 18 21:36:31 hebus postfix/smtpd[2173]: disconnect from unknown[192.168.173.254]
Jan 18 21:36:31 hebus postfix/smtpd[2174]: lost connection after CONNECT from unknown[192.168.173.254]
Jan 18 21:36:31 hebus postfix/smtpd[2174]: disconnect from unknown[192.168.173.254]
Jan 18 21:36:31 hebus postfix/smtpd[2173]: connect from unknown[192.168.173.254]
Jan 18 21:36:31 hebus postfix/smtpd[2173]: lost connection after CONNECT from unknown[192.168.173.254]
Jan 18 21:36:31 hebus postfix/smtpd[2173]: disconnect from unknown[192.168.173.254]
Jan 18 21:36:31 hebus postfix/smtpd[2174]: connect from unknown[192.168.173.254]
Jan 18 21:36:31 hebus postfix/smtpd[2174]: lost connection after CONNECT from unknown[192.168.173.254]
Jan 18 21:36:31 hebus postfix/smtpd[2174]: disconnect from unknown[192.168.173.254]
I am having this problem to. I can't add an account to thunderbird meaning I am ditching Thunderbird and switching to another programm. 

Even when Thunderbird can't find the settings for an account you should be able to add the account!!!
This is extremely inconvenient as it requires the account to exist prior to creation. Additionally not having "advanced configuration" prevents detailed troubleshooting where ports are blocked by network etc. There should always be the option to create the account anyway.

Workaround: 
1. Create an account called "test@gmail.com" 
2. Press "Manual Config"
3. Press "Advanced Config"
4. Edit everything.
Still reproducible in Thunderbird 24.

Can we at least have the option to skip the automatic detection and create an empty account?

Thanks in davance.
Severity: normal → blocker
Version: 17 → 24
(In reply to Ken Fallon from comment #2)
> This is extremely inconvenient as it requires the account to exist prior to
> creation. Additionally not having "advanced configuration" prevents detailed
> troubleshooting where ports are blocked by network etc. There should always
> be the option to create the account anyway.
> 
> Workaround: 
> 1. Create an account called "test@gmail.com" 
> 2. Press "Manual Config"
> 3. Press "Advanced Config"
> 4. Edit everything.

Advanced config is grayed out. This does not work.
(In reply to Martijn from comment #1)
> Even when Thunderbird can't find the settings for an account you should be able to add the account!!!
As wrote by Ken Fallon in comment #2, there is "Manual Config".
Do you mean "Manual Config" was not shown?
If so, you clicked "Stop" while Tb is trying to do auto-config for the non-existent account?
(In reply to Matthieu Pupat from comment #4)
> (In reply to Ken Fallon from comment #2)
> > Workaround: 
> > 1. Create an account called "test@gmail.com" 
> > 2. Press "Manual Config"
> > 3. Press "Advanced Config"
> > 4. Edit everything.
> Advanced config is grayed out. This does not work.
Heve you correctly set each field in panel shown by "Manual Config" at step 2?

Unless at least "SSL(or Port) and Authentication" is changed from Autodetect(or Auto if Port) and an option is selected for them, "Advanced Config" button is kept grayed out, because you are still requesting automatic configuration by choosing "Autodetect" or "Auto".

Please note that purpose of "Manual Config" is never "create an empty account". Purpose of "Manual Config" is quick manual filling of minimum required settings which is requested by ISP.

(In reply to Matthieu Pupat from comment #3)
> Can we at least have the option to skip the automatic detection and create an empty account?
There is no way to skip first "ISP database check" step. You have to click "Continue" at first panel.
However, you can kill the first "ISP database check" step" and skip subsequent automatic detection steps by clicking "Manual Config" button.

It's never difficult, but is pretty confusing if user tried manual setup the first time.
So, IIRC, "Manual Config" button in first panel or equivallent is requested, in addition to current "Continue" button.
Meaning of "Manual Config" is slightly diferent in first panel and second panel after "Continue" button is clicked.
  At first panel : Skip all automatic detection including ISP database check.
  At second panel after "Continue" : Skip automatic detection currently executed.
So, following may be better for us.
  First panel : "Continue"->"Auto-Detect", add "Skip Auto-Detect" buttton
Importance fields are never for user's thought on problem, and keywords in Severity(second box) is defined term. So, this bug can't be "Blocker".
Severity: blocker → normal
Thanks for all the explanations. I guess with this somewhat complicated workaround this is not a blocker but until now it just looked like it as I was not able too use Thunderbird for reading my emails.

BTW the server I use has a pretty standard configuration: SSL/TLS on port 993. This should probably be tried on the automatic detection.
I have seen this error happen intermittently. The solution for me is to restart the Postfix service and try again. Usually it will work the second go-round.
I'm gonna suggest this be marked as a duplicate of Bug 647761, which is the larger and older bug describing in effect the same problem.
When I change to a new email from another ISP provider, I cannot setup the email account using the provided non-standard smtp and pop server names. Thunderbird force to do it automatically for you. Although I have made some workaround by using a gmail account firstly. I cannot edit the smtp server. Please don't think Thunderbird can do everything and let user edit it manually when it is required.
Thunderbird version is 31.5.0
Thanks
hello, the problem is:
"With Postfix 2.6 and later, the SMTP server sets a per-session flag whenever it detects illegal pipelining, including pipelined HELO or EHLO commands."

now, 1) Postfix guys don't explain how to remove this "flag"
2) the method used by Thunderbird to connect for "autoconfiguration" is wrong for sure.

We're in 2015 and we can't use this good feature?
Please fix.
Thanks
I'm trying to understand if it's a problem by DNS on external domain (not directly managed by my server)...but I have to wait for the propagation.
At the moment, as I thought I have this on access log
/var/log/system/mydomain.com_access_log:MY_IP - - [18/Jun/2015:19:36:29 +0200] "GET /.well-known/autoconfig/mail/config-v1.1.xml?emailaddress=myuser%40mydomain.com HTTP/1.1" 404 241 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64;
rv:31.0) Gecko/20100101 Thunderbird/31.7.0"
/var/log/system/mydomain.com_access_log:MY_IP - - [18/Jun/2015:19:38:17 +0200] "GET /.well-known/autoconfig/mail/config-v1.1.xml?emailaddress=myuser%40mydomain.com HTTP/1.1" 404 241 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64;
rv:31.0) Gecko/20100101 Thunderbird/31.7.0"
/var/log/system/mydomain.com_access_log:MY_IP - - [18/Jun/2015:19:56:16 +0200] "GET /.well-known/autoconfig/mail/config-v1.1.xml?emailaddress=myuser%40mydomain.com HTTP/1.1" 404 241 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64;
rv:31.0) Gecko/20100101 Thunderbird/31.7.0"
/var/log/system/mydomain.com_access_log:MY_IP - - [18/Jun/2015:21:04:33 +0200] "GET /.well-known/autoconfig/mail/config-v1.1.xml?emailaddress=myuser%40mydomain.com HTTP/1.1" 404 241 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64;
rv:31.0) Gecko/20100101 Thunderbird/31.7.0"
/var/log/system/mydomain.com_access_log:MY_IP - - [18/Jun/2015:21:06:44 +0200] "GET /.well-known/autoconfig/mail/config-v1.1.xml?emailaddress=myuser%40mydomain.com HTTP/1.1" 404 241 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64;
rv:31.0) Gecko/20100101 Thunderbird/31.7.0"

obviously the .well-known dir doesn't exist and the host autoconfig was not set.
Anyway, I don't understand why that error with Postfix... maybe wrong variables?
I will try again after the DNS propagation...
bye for now
OK, CONFIRMED. NOT A BUG. Sorry, Mozilla :-)
the issue is caused by a not set DNS A record for Host name "autoconfig"

So, if you find this issue:
1) client side: you have to contact your ISP which has to correctly follow this tutorial
https://developer.mozilla.org/en-US/docs/Mozilla/Thunderbird/Autoconfiguration

2) server side: make sure you set the correct DNS records and path/cgi for your customers

bye bye
(In reply to kevin from comment #10)
> I have seen this error happen intermittently. The solution for me is to
> restart the Postfix service and try again. Usually it will work the second
> go-round.

Kevin, do you still see this issue?
Component: Untriaged → Account Manager
Flags: needinfo?(kevin)
Summary: Thunderbird failed to find the settings for your email account → "Thunderbird failed to find the settings for your email account"
Came across this bug attempting to set up a test account for a dovecot install. The autoconfig correctly detects settings for the live system; however logs indicate that upon changing settings manually, the username is zapped and a blank username is sent to the server. Attempting to further alter settings / username manually does not fix.
Flags: needinfo?(kevin)
Summary: "Thunderbird failed to find the settings for your email account" → "Thunderbird failed to find the settings for your email account" [autoconfig]
I would like to confirm this issue the Mail Setup Wizard never works. It basically stays on the page where you fill all the account details and testing does not work. Also Done button is greyed out so one have to only click on cancel.

This is very annoying issue which has been in Thunderbird for ages. Please can you simply let users to add the details and save the account with whatever they want?

> "the issue is caused by a not set DNS A record for Host name "autoconfig""

Yes,  I believe this is the issue. Mozilla dev, please understand that not everyone have autoconfig DNS records.

Thanks
Hello,
I reproduce same error "improper command pipelining after EHLO from unknown[192.168.61.1]: QUIT\r\n"
 configuring an account using latest thunderbird 60 beta6 (it's blocker for me).
This is obviously smooth sailing for ISP accounts, but a significant proportion of Thunderbird users run their own mailservers.

Failing the test when the user enters all their details correctly violates the Law of Least Astonishment. Ditto keeping Advanced Config greyed out unless the user fills in every single field. There's no indication what the user needs to do to get to the real Account Settings dialog. At least make it easy to do that.

Thunderbird 52.9.0
(In reply to ipatrol from comment #11)
> I'm gonna suggest this be marked as a duplicate of Bug 647761, which is the
> larger and older bug describing in effect the same problem.

Ben, do you agree?
Flags: needinfo?(ben.bucksch)
They are both invalid, so I don't mind either way :)
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Flags: needinfo?(ben.bucksch)
Resolution: --- → DUPLICATE
Duplicate of bug: 647761
You need to log in before you can comment on or make changes to this bug.