Top of status bar should be aligned with top of window's grow box [mac osx]

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
18 years ago
5 years ago

People

(Reporter: mpt, Unassigned)

Tracking

({classic})

Trunk
PowerPC
Mac OS X
classic
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: 2001052904, Mac OS 9.1, Classic theme

To reproduce:
*   Open a Navigator, three-pane, Composer, Address Book, or message composition
    window.
*   Look at the right end of the status bar.

What you should see:
*   The 1px black line along the top of the status bar aligns exactly with the
    1px black line at the top of the window's grow box.

What you actually see:
*   The 1px black line along the top of the status bar is about 9 pixels too
    high.

This is a recent regression, probably caused by the fix to stop component icons
appearing off-screen after the taskbar went away. It makes the windows look
quite unprofessional.

Comment 1

18 years ago
Yes, I know.  This was the unwanted side - effect of fixing the cut-off 
taskbar buttons. The real issue is to fix all the images such that they do 
not take up so  much vertical space, and reduce the margins around the 
taskbar buttons.

You'll notice that modern does this as well only not as much.


Adding Marlon to cc list.
Setting Priority.

I'm going to file a meta bug for all the status bar issues and start knocking 
them out one by one.

Yep this is bad and is in my top 10 list of stuff for 0.9.2
Status: NEW → ASSIGNED
Priority: -- → P1

Comment 2

18 years ago
that's not intentional.  it will line up once i am finished with the new taskbar 

Updated

18 years ago
Target Milestone: --- → mozilla0.9.2
(Reporter)

Comment 3

18 years ago
Marlon, I think making the icons any smaller is rather a bad idea -- they're
pushing the boundaries of recognizability as it is.

Why not do what 4.x did, and make the icons darker when they're clicked? (That
would require considerably less work, too.)

Comment 4

18 years ago
i don't understand, what do you mean by making them darker when they're clicked?  
how does that allow them to fit into 14px (height of Mac grow box)?   I agree 
14px is very short, but i have some that work fairly well (with the exception of 
the browser icon that is)
(Reporter)

Comment 5

18 years ago
> what do you mean by making them darker when they're clicked?

Like they are in 4.x. Like the `Home' button is in Seamonkey. And like the 
Security and Online/Offline icons should be (but currently aren't).

> how does that allow them to fit into 14px (height of Mac grow box)?

It means that you can treat them as icons, rather than as buttons. So they 
don't need a button border, or padding between the icon and the button border, 
or padding between the button border and the edge of the status bar.

Comment 6

18 years ago
o i c your point now.  i haven't decided yet on making it work the modern6 way.i 
may still use a button, but they'd behave much like the formatting buttons are 
now (which still need some work), wouldn't need the vertical padding.  i have to 
test the spacing out

Updated

18 years ago
Blocks: 83551

Comment 7

17 years ago
themes triage: moving to mozilla 1.0.  P3
Priority: P1 → P3
Target Milestone: mozilla0.9.2 → mozilla1.0
(Reporter)

Updated

17 years ago
Blocks: 91504
(Reporter)

Comment 8

17 years ago
*** Bug 92811 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Keywords: mozilla1.0

Comment 9

17 years ago
((waiting for new icons keyword to be added to bugzilla, to add it here.))

Updated

17 years ago
Keywords: classic

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 10

16 years ago
*** Bug 147296 has been marked as a duplicate of this bug. ***
The Mac OS 8/9 Mozilla is no longer supported.  Should this bug still be open?
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Comment 13

14 years ago
RIP Classic.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 14

13 years ago
Reproduced in Mozilla build 2005070211, Mac OS 10.3.9. Reopening.
Status: RESOLVED → REOPENED
OS: Mac System 9.x → MacOS X
Resolution: WONTFIX → ---
Target Milestone: mozilla1.0.1 → ---
(Reporter)

Updated

13 years ago
Assignee: andreww → nobody
Status: REOPENED → NEW
QA Contact: pmac → themes

Updated

13 years ago
Summary: Top of status bar should be aligned with top of window's grow box → Top of status bar should be aligned with top of window's grow box [mac osx]
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey

Comment 15

5 years ago
This issue have been fixed for a long time ago. The resizer is now inside a statusbarpanel.
Status: NEW → RESOLVED
Last Resolved: 14 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.