If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Firefox Graveyard
Developer Tools: 3D View
P1
normal
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: paul, Assigned: vporof)

Tracking

Trunk
Firefox 21
x86
All

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:
- open a new window
- start the inspector
- start tilt
- close the toolbox
- press ESC to stop tilt
- start the inspector
- see Tilt button being active (it should not)
- click on Tilt button
- Tilt doesn't start  (it should)
(Reporter)

Updated

5 years ago
Blocks: 831711
(Assignee)

Comment 1

5 years ago
Timestamp: 1/21/13 7:01:55 PM
Error: TypeError: this.inspector.selection is null
Source File: resource://gre/modules/devtools/TiltVisualizer.jsm
Line: 197

..when tilt is closed via ESC after closing the toolbox.
No longer blocks: 831711
(Assignee)

Updated

5 years ago
Blocks: 831711
(Reporter)

Comment 2

5 years ago
cc'ing Optimizer, as I think it's related to how we handle the toggle state of the Tilt button.
I think that since the TiltVisualizer gave an exception, it does not restarts as the script has already exception-ed out.

The problem is basically that inspector.selecito is alredy gone by the time TileVisualizer tries to remove an event handler.
(Assignee)

Comment 4

5 years ago
(In reply to Girish Sharma [:Optimizer] from comment #3)
> I think that since the TiltVisualizer gave an exception, it does not
> restarts as the script has already exception-ed out.
> 
> The problem is basically that inspector.selecito is alredy gone by the time
> TileVisualizer tries to remove an event handler.

Wanna fix it? :)
(Reporter)

Updated

5 years ago
Blocks: 816946
(Reporter)

Comment 5

5 years ago
This is pretty bad. We want to fix that in Firefox Aurora (firefox 20).
Priority: -- → P1
(Assignee)

Comment 6

5 years ago
Created attachment 704892 [details] [diff] [review]
v1

Ok.
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #704892 - Flags: review?(paul)
(Reporter)

Comment 7

5 years ago
Comment on attachment 704892 [details] [diff] [review]
v1

Thank you Victor.
Attachment #704892 - Flags: review?(paul) → review+
(Assignee)

Updated

5 years ago
Whiteboard: [land-in-fx-team]
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/9225e25e3f1e
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
(Assignee)

Comment 9

5 years ago
Comment on attachment 704892 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Users won't be able to start the 3D view in some cases
User impact if declined: medium for developers, small for regular users
Testing completed (on m-c, etc.): fx-team
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none
Attachment #704892 - Flags: approval-mozilla-aurora?
status-firefox20: --- → affected
status-firefox21: --- → affected
tracking-firefox20: --- → +
https://hg.mozilla.org/mozilla-central/rev/9225e25e3f1e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 21

Updated

5 years ago
status-firefox21: affected → fixed

Updated

5 years ago
Attachment #704892 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/bd00c6ae955e

Updated

5 years ago
status-firefox20: affected → fixed
relnote-firefox: --- → ?

Updated

5 years ago
status-firefox19: --- → unaffected
relnote-firefox: ? → ---

Comment 12

5 years ago
Verified as fixed on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
status-firefox20: fixed → verified

Comment 13

4 years ago
Verified as fixed on Firefox 21 RC - 20130507015204.
status-firefox21: fixed → verified
No longer blocks: 831711
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.