Last Comment Bug 833028 - Subjects with mixed ASCII and MIME words are incorrectly displayed
: Subjects with mixed ASCII and MIME words are incorrectly displayed
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Message Reader UI (show other bugs)
: 20 Branch
: All All
: -- normal (vote)
: Thunderbird 22.0
Assigned To: Zane U. Ji
:
:
Mentors:
Depends on: 493544
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-21 10:24 PST by Alfred Peters
Modified: 2013-03-09 16:18 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
example.eml (843 bytes, application/octet-stream)
2013-01-21 10:24 PST, Alfred Peters
no flags Details
Test case (1.00 KB, patch)
2013-01-23 04:29 PST, Zane U. Ji
smontagu: review+
Details | Diff | Splinter Review
Patch (1.59 KB, patch)
2013-01-23 04:30 PST, Zane U. Ji
smontagu: review+
Details | Diff | Splinter Review
For mailnews checkin (1.03 KB, patch)
2013-03-07 06:31 PST, Zane U. Ji
no flags Details | Diff | Splinter Review
For mozilla checkin (1.27 KB, patch)
2013-03-07 06:32 PST, Zane U. Ji
no flags Details | Diff | Splinter Review

Description Alfred Peters 2013-01-21 10:24:50 PST
Created attachment 704594 [details]
example.eml

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20130118 Firefox/21.0
Build ID: 20130118213347

Steps to reproduce:

Look at an E-Mail or Newsgroup Article that has an Subject with mixed ASCII and MIME words.
Example: mozilla.test
       news://news.mozilla.org:119/mLCdneUfb6GbG2DNnZ2dnUVZ_vadnZ2d@mozilla.org

RAW Subject: AAA =?UTF-8?Q?bbb?= CCC =?UTF-8?Q?ddd?= EEE =?UTF-8?Q?fff?= GGG



Actual results:

Subject is displayed as: AAA  CCC  EEE bbbdddfff GGG




Expected results:

Should be displayed as: AAA bbb CCC ddd EEE fff GGG
Comment 1 Alfred Peters 2013-01-21 10:33:11 PST
This Bug is caused by attachment 695139 [details] [diff] [review] from Bug 493544

Tested on TB and SM by backing out that patch.
Comment 2 Masatoshi Kimura [:emk] 2013-01-23 03:48:28 PST
@ZaneUJi: Could you move your patches from bug 493544?
Comment 3 Zane U. Ji 2013-01-23 04:29:06 PST
Created attachment 705313 [details] [diff] [review]
Test case
Comment 4 Zane U. Ji 2013-01-23 04:30:20 PST
Created attachment 705314 [details] [diff] [review]
Patch
Comment 5 Zane U. Ji 2013-03-07 06:31:01 PST
Created attachment 722220 [details] [diff] [review]
For mailnews checkin
Comment 6 Zane U. Ji 2013-03-07 06:32:23 PST
Created attachment 722221 [details] [diff] [review]
For mozilla checkin
Comment 7 Ryan VanderMeulen [:RyanVM] 2013-03-08 05:33:31 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/2c4a8bdb41eb

I'll land the mailnews patch once this is merged over to m-c.
Comment 8 Ryan VanderMeulen [:RyanVM] 2013-03-09 16:02:43 PST
https://hg.mozilla.org/comm-central/rev/41087bd62c93
Comment 9 Ryan VanderMeulen [:RyanVM] 2013-03-09 16:18:36 PST
https://hg.mozilla.org/mozilla-central/rev/2c4a8bdb41eb

Note You need to log in before you can comment on or make changes to this bug.