If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[RFE] Send contents of .x-face config file in X-Face header

RESOLVED WONTFIX

Status

MailNews Core
Networking: NNTP
--
enhancement
RESOLVED WONTFIX
17 years ago
8 years ago

People

(Reporter: Garth Wallace, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
On UNIX systems, the .x-face file in a user's home directory is used to store a
text-encoded black & white image for use in the X-Face header on newsgroups. I
think that Mozilla should support this file and send its contents in X-Face when
posting.

This is not the same as bug #20417. That has to do with displaying an X-Face,
and therefore decoding it. This is for sending a pre-encoded X-Face, which
requires no decoding or display.
cc'ing sfmr (the author of "Send Face" for the mac)

way future.

there are no plans to implement this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Future

Comment 2

17 years ago
It's called "Saving Face" and is based on xface code by James Ashton.

Do we have an 'extra news/mail headers' area where people can paste their x-face 
header?
no, we don't have a way to do arbitrary headers yet, but that's been requested
before.  (I believe by dawn or dmose, something they needed.  it was a long time
ago).  support for a single aribrary header (set in your prefs) may have even
made it into the product, but that might have bit rotted by now.

if I'm not dreaming and that code hasn't bit rotted, you could set some prefs
and then if you wanted to included your X-Face, you'd have to paste it in every
time.

(Reporter)

Comment 4

17 years ago
Arbitrary headers is bug #16925.

Comment 5

15 years ago
Reporter : check if this one is not a dupe of 20417 or 83364

Adding this one to 176238 tracking bug
Blocks: 176238

Updated

15 years ago
No longer blocks: 176238
(Reporter)

Comment 6

15 years ago
Yves: this bug is a subset of bug 20417. 20417 also subsumes decoding/display of
X-Face, and possibly encoding as well. This bug was opened because I believe
that simply sending a pre-encoded X-Face would require less coding and therefore
would be more likely to get included sooner.

Not sure why you're asking if this is a dup of 83364, because this *is* 83364.

Comment 7

13 years ago
CC
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: stephend → networking.news
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
As the X-Face bug is WONTFIX, this bug is also WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.