Tabs/Private/Synced menu pops up unexpectedly

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: kats, Assigned: sriram)

Tracking

unspecified
Firefox 21
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 verified, firefox21 verified)

Details

(Whiteboard: [↑↑↓↓←→←→BA])

Attachments

(2 attachments)

Posted image Screenshot
STR (on my Galaxy Nexus):

Start Fennec
Load a page (e.g. SUMO) and wait for it to finish
Tap gently in the top-left corner of the awesomebar (above and to the left of the favicon, just below the Android notification bar).

Actual results:
Secret menu! See attached

Expected results:
Secret items should be harder to find, e.g. only visible after entering the konami code.
Assignee: nobody → sriram
Whiteboard: [↑↑↓↓←→←→BA]
I am thinking of removing all the contents of tabs-ui once we close it. That would help this bug. Basically the "Spinner" is taking the focus and the taps.
Posted patch PatchSplinter Review
This consumes the events and doesn't allow it to pass to elements underneath it.
Attachment #707319 - Flags: review?(mark.finkle)
Comment on attachment 707319 [details] [diff] [review]
Patch

Does this go away when we change to icon buttons/tabs ?
(In reply to Mark Finkle (:mfinkle) from comment #3)
> Comment on attachment 707319 [details] [diff] [review]
> Patch
> 
> Does this go away when we change to icon buttons/tabs ?

No. This problem persists even with icon button-tabs.
Basically a LinearLayout is not like a layout we see in other windowing systems. Events pass through the LinearLayout to elements underneath them, if their children require it.
Earlier we just had a text, so we didn't see this problem. On right side, the tabs and menu buttons have click listeners and so the events aren't "passing through".
On left side, if we allow (default) pass through of events, the icon-tabs / spinner / any button will get the click event.
Comment on attachment 707319 [details] [diff] [review]
Patch

Then let's do it!
Attachment #707319 - Flags: review?(mark.finkle) → review+
Assignee

Updated

7 years ago
Blocks: 817675
https://hg.mozilla.org/mozilla-central/rev/796e350770b8
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 707319 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Long time bug. Known only now.
User impact if declined: Tapping on left most edge of browser will show the tab-ui menu options. (This is easily tappable).
Testing completed (on m-c, etc.): Landed on m-c 01/31
Risk to taking this patch (and alternatives if risky): Very low. This just avoids events from progragating.
String or UUID changes made by this patch: None.
Attachment #707319 - Flags: approval-mozilla-aurora?
Attachment #707319 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 10

6 years ago
Verified using Galaxy Nexus (Android 4.1.2) on:
Nightly 21.0a1(2013-02-07) and Aurora 20.0a2(2013-02-07).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.