The wrong SplayTree.h is ending up in dist/include/mozilla, causing build error: "Cannot open include file: 'lifoalloc.h'

RESOLVED FIXED in Firefox 20

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Benjamin Smedberg, Assigned: Benjamin Smedberg)

Tracking

unspecified
mozilla21
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox20+ fixed, firefox21 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
I don't know why the tinderbox and everyone isn't seeing this, but it may have to do with the relative timestamp of files or something.

There are currently two SplayTree.h files in the tree: mfbt/SplayTree.h and js/src/ds/SplayTree.h. In my local clobber build, the js (wrong) one is ending up in dist/include/mozilla/SplayTree.h

This is because when we are building in js/src, we include mfbt/exported_headers.mk. This tries to install SplayTree.h, but js/src/Makefile.in puts $(srcdir)/ds in front of mfbt in the VPATH.
(Assignee)

Updated

5 years ago
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
(Assignee)

Comment 1

5 years ago
Created attachment 705424 [details] [diff] [review]
Put MFBT first in the VPATH, rev. 1
Attachment #705424 - Flags: review?(khuey)
Comment on attachment 705424 [details] [diff] [review]
Put MFBT first in the VPATH, rev. 1

Review of attachment 705424 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/Makefile.in
@@ +57,5 @@
> +###############################################
> +# BEGIN include sources for low-level code shared with mfbt
> +#
> +MFBT_ROOT = $(srcdir)/../../mfbt
> +VPATH += $(MFBT_ROOT)

Why += instead of = like we had before?
Attachment #705424 - Flags: review?(khuey) → review+
(Assignee)

Comment 3

5 years ago
Why not? Makes it easier to refactor in the future if warranted.
/me shrugs
https://hg.mozilla.org/mozilla-central/rev/cf2a37861425
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Duplicate of this bug: 835735
For me that patch is needed to build Firefox 20 at all. Can it be considered for a patch in 20?
tracking-firefox20: --- → ?
Comment on attachment 705424 [details] [diff] [review]
Put MFBT first in the VPATH, rev. 1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 822906
User impact if declined: Failure to build aurora
Testing completed (on m-c, etc.): Landed on m-c a while ago
Risk to taking this patch (and alternatives if risky): Very low
String or UUID changes made by this patch: None
Attachment #705424 - Flags: approval-mozilla-aurora?

Updated

5 years ago
tracking-firefox20: ? → +

Comment 9

5 years ago
Comment on attachment 705424 [details] [diff] [review]
Put MFBT first in the VPATH, rev. 1

Tracking and approving on behalf of developers and Linux distros.
Attachment #705424 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/5bbf98e5690a
status-firefox20: --- → fixed
status-firefox21: --- → fixed
You need to log in before you can comment on or make changes to this bug.