Closed Bug 835735 Opened 7 years ago Closed 7 years ago

compilation fails on Linux not finding LifoAlloc.h

Categories

(Firefox Build System :: General, defect)

20 Branch
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 833863

People

(Reporter: wolfiR, Unassigned)

Details

compilation fails on Linux not finding LifoAlloc.h

e.g.
[ 1874s] c++ -o FrameLayerBuilder.o -c -I../../dist/stl_wrappers -I../../dist/system_wrappers -include /home/abuild/rpmbuild/BUILD/mozilla/config/gcc_hidden.h -DMOZ_GLUE_IN_PROGRAM -DMOZI
LLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DSTATIC_EXPORTABLE_JS_API -DNO_NSPR_10_SUPP
ORT -DEXCLUDE_SKIA_DEPENDENCIES  -DOS_POSIX=1 -DOS_LINUX=1  -D_IMPL_NS_LAYOUT -DHB_DONT_DEFINE_STDINT -I/home/abuild/rpmbuild/BUILD/mozilla/ipc/chromium/src -I/home/abuild/rpmbuild/BUILD/
mozilla/ipc/glue -I../../ipc/ipdl/_ipdlheaders  -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base/../style -I/home/abuild/rpmbuild/BUILD/
mozilla/layout/base/../generic -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base/../forms -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base/../tables -I/home/abuild/rpmbuild/BUILD/mozilla
/layout/base/../printing -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base/../xul/base/src -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base/../xul/base/src/tree/src -I/home/abuild/rpmbui
ld/BUILD/mozilla/layout/base/../../content/base/src -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base/../../content/events/src -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base/../../cont
ent/xbl/src -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base/../../view/src -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base/../../dom/base -I/home/abuild/rpmbuild/BUILD/mozilla/layout/
base/../../content/html/content/src -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base/../../content/svg/content/src -I/home/abuild/rpmbuild/BUILD/mozilla/xpcom/ds -I/home/abuild/rpmbuild/
BUILD/mozilla/layout/base/../svg -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base/../mathml  -I/home/abuild/rpmbuild/BUILD/mozilla/layout/base -I. -I../../dist/include  -I/usr/include/ns
pr4 -I/usr/include/nss3      -fPIC  -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-o
ffsetof -Wno-variadic-macros -Wcast-align -Wno-long-long -fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -g -Os -fno-strict
-aliasing -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks  -fomit
-frame-pointer  -I/home/abuild/rpmbuild/BUILD/obj/dist/include/cairo    -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MF .deps/FrameLayerBuilder.o.pp  /home/abuild/rpmbuild/BUILD/
mozilla/layout/base/FrameLayerBuilder.cpp
[ 1874s] MaskLayerImageCache.cpp
[ 1874s] In file included from /home/abuild/rpmbuild/BUILD/mozilla/layout/style/../base/RestyleTracker.h:18:0,
[ 1874s]                  from /home/abuild/rpmbuild/BUILD/mozilla/layout/style/../base/nsCSSFrameConstructor.h:24,
[ 1874s]                  from /home/abuild/rpmbuild/BUILD/mozilla/layout/style/AnimationCommon.cpp:9:
[ 1874s] ../../dist/include/mozilla/SplayTree.h:11:23: fatal error: LifoAlloc.h: No such file or directory
[ 1874s] compilation terminated.
[ 1874s] make[6]: *** [AnimationCommon.o] Error 1
yes, it is. Thanks for the pointer
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 833863
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.