[USB Mass Storage] Media Storage and Device Storage Subtitles Disappear

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: delphine, Assigned: dhylands)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxos:media])

Reproducible:
* Connect phone to computer via USB cable
* Open Settings/Media Storage
* Click USB mass storage
* Click the back button

Expected:
* Device and Media storage subtitles show the space available

Actual:
* No subtitle under Device Storage nor Media Storage
* If I unmount USB and take out the cable, and go back to Settings, there is only subtitle for Media storage

There seems to be some variants possible, but in any case, the storage subtitles should appear.

You need to either block the phone and then unblock it, or to go back to the homescreen, for the subtitles to appear again.
Probably a cache problem.
Assignee: nobody → doug.turner
QA Contact: lebedel.delphine
Probably regression from Bug 826739?
Keywords: regression

Comment 2

4 years ago
david probably can look into this.
Assignee: doug.turner → dhylands
Still an issue as of today on Unagi, 
v1 pvt nightly build
Gaia   87801b12cd3aac153fae84844da8f1e6455ea679
BuildID 20130308070202
Version 18.0
(Assignee)

Comment 4

4 years ago
So I tested this today, and I only see the Media Storage subtitle disappear. The Device Storage subtitle remains.

This is actually expected. The volume isn't accessible by the phone while it's being shared with the PC, so there's no way for it to know how much space is available until you disable UMS.

We could perhaps display something to indicate that the volume is currently shared with the PC, rather than displaying nothing.
Ok so I just reflashed my phone fresh to check, and you are right. I do not get the same error anymore.

I agree that we could maybe display something to indicated that the volume is currently shared with the PC?
(Assignee)

Comment 6

3 years ago
Added [fxos:media] whiteboard for bugs assigned to me so that they can be triaged/prioritized, etc.
Whiteboard: [fxos:media]

Comment 7

2 years ago
Dave is it still a valid issue?
Flags: needinfo?(dhylands)
(Assignee)

Comment 8

2 years ago
It seems to be working fine for me. I suspect that this code has been reworked quite a bit since this bug was originally filed, so I'm happy to mark this as "Works For Me".
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(dhylands)
Resolution: --- → WORKSFORME

Comment 9

2 years ago
Thanks!
You need to log in before you can comment on or make changes to this bug.