Last Comment Bug 834115 - [USB Mass Storage] Media Storage and Device Storage Subtitles Disappear
: [USB Mass Storage] Media Storage and Device Storage Subtitles Disappear
Status: RESOLVED WORKSFORME
[fxos:media]
: regression
Product: Firefox OS
Classification: Client Software
Component: Gaia::Settings (show other bugs)
: unspecified
: ARM Gonk (Firefox OS)
: -- normal (vote)
: ---
Assigned To: Dave Hylands [:dhylands]
: Delphine Lebédel [:delphine - use need info]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-23 19:19 PST by Delphine Lebédel [:delphine - use need info]
Modified: 2015-11-06 15:38 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Delphine Lebédel [:delphine - use need info] 2013-01-23 19:19:17 PST
Reproducible:
* Connect phone to computer via USB cable
* Open Settings/Media Storage
* Click USB mass storage
* Click the back button

Expected:
* Device and Media storage subtitles show the space available

Actual:
* No subtitle under Device Storage nor Media Storage
* If I unmount USB and take out the cable, and go back to Settings, there is only subtitle for Media storage

There seems to be some variants possible, but in any case, the storage subtitles should appear.

You need to either block the phone and then unblock it, or to go back to the homescreen, for the subtitles to appear again.
Probably a cache problem.
Comment 1 Delphine Lebédel [:delphine - use need info] 2013-01-25 13:48:44 PST
Probably regression from Bug 826739?
Comment 2 Doug Turner (:dougt) 2013-01-28 13:05:40 PST
david probably can look into this.
Comment 3 Delphine Lebédel [:delphine - use need info] 2013-03-08 14:12:09 PST
Still an issue as of today on Unagi, 
v1 pvt nightly build
Gaia   87801b12cd3aac153fae84844da8f1e6455ea679
BuildID 20130308070202
Version 18.0
Comment 4 Dave Hylands [:dhylands] 2013-03-08 14:21:07 PST
So I tested this today, and I only see the Media Storage subtitle disappear. The Device Storage subtitle remains.

This is actually expected. The volume isn't accessible by the phone while it's being shared with the PC, so there's no way for it to know how much space is available until you disable UMS.

We could perhaps display something to indicate that the volume is currently shared with the PC, rather than displaying nothing.
Comment 5 Delphine Lebédel [:delphine - use need info] 2013-03-08 14:42:13 PST
Ok so I just reflashed my phone fresh to check, and you are right. I do not get the same error anymore.

I agree that we could maybe display something to indicated that the volume is currently shared with the PC?
Comment 6 Dave Hylands [:dhylands] 2014-01-08 17:28:51 PST
Added [fxos:media] whiteboard for bugs assigned to me so that they can be triaged/prioritized, etc.
Comment 7 Fred Lin [:gasolin] 2015-11-05 23:51:59 PST
Dave is it still a valid issue?
Comment 8 Dave Hylands [:dhylands] 2015-11-06 13:01:50 PST
It seems to be working fine for me. I suspect that this code has been reworked quite a bit since this bug was originally filed, so I'm happy to mark this as "Works For Me".
Comment 9 Fred Lin [:gasolin] 2015-11-06 15:38:37 PST
Thanks!

Note You need to log in before you can comment on or make changes to this bug.