Closed Bug 834186 Opened 8 years ago Closed 7 years ago

Display framerate

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1007202

People

(Reporter: Yoric, Unassigned)

Details

(Keywords: perf, Whiteboard: [performance] [c=devtools p= s= u=])

Framerate and cpu load would be interesting informations for application developers.
Framerate display can be enabled with "layers.acceleration.draw-fps" but it only works on OpenGL (not Windows) as far as I know

See bugs 612407 and 780467
Yes, and we also have window.mozPaintCount that could be used in a more generic manner.
we actually have an addon that makes use of this.

https://github.com/pcwalton/firefox-framerate-monitor

It would be pretty easy to turn this into a shipping feature. Not sure where we'd put it, but I'd like to see it on our Developer Toolbar.
Whiteboard: [performance]
I'm moving this into the profiler. We'd like to capture framerates during profiles and display them alongside the stackdepth as well.
Component: Developer Tools → Developer Tools: Profiler
Depends on: 879008
We should open a separate bug to display CPU levels since we don't have easy access to that, afaik. framerates we will do.
Priority: -- → P2
Summary: Display framerate and cpu load → Display framerate
tagging this so the b2g perf team can track this work.
Keywords: perf
Whiteboard: [performance] → [performance] [c=devtools p= s= u=]
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1007202
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.