Missing text and garbled characters problems in some Japanese PDFs

RESOLVED DUPLICATE of bug 842589

Status

()

Firefox
PDF Viewer
RESOLVED DUPLICATE of bug 842589
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Assigned: yury)

Tracking

({intl, jp-critical})

Trunk
intl, jp-critical
Points:
---

Firefox Tracking Flags

(firefox19- wontfix, firefox20+ fixed, firefox21+ fixed)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/2581)

Attachments

(1 attachment, 1 obsolete attachment)

80.55 KB, image/png
Details
(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/98ea4d294369
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130124 Firefox/21.0 ID:20130124054158

PDF links in site( http://ybb.softbank.jp/support/connect/adsl/setupguide.html )

(Ex.. http://ybb.softbank.jp/support/connect/adsl/pdf/4g_set03.pdf )
I couldn't find the garbled character. Could you be more specific?
(But surely some warnings are displayed to the Web Console.)
(Reporter)

Comment 2

5 years ago
Created attachment 706258 [details]
Screenshot
(Reporter)

Comment 3

5 years ago
(In reply to Masatoshi Kimura [:emk] from comment #1)
> I couldn't find the garbled character. Could you be more specific?
> (But surely some warnings are displayed to the Web Console.)

See screen shot attachment 706258 [details]
(Reporter)

Comment 4

5 years ago
It works if HWA disabled.

My default  Graphics section:

        Adapter Description
        ATI Radeon HD 4300/4500 Series

        Adapter Drivers
        aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64

        Adapter RAM
        512

        ClearType Parameters
        Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 50

        Device ID
        0x954f

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7601.17789)

        Driver Date
        11-16-2012

        Driver Version
        8.970.100.7000

        GPU #2 Active
        false

        GPU Accelerated Windows
        2/2 Direct3D 10

        Vendor ID
        0x1002

        WebGL Renderer
        Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series)

        AzureCanvasBackend
        direct2d

        AzureContentBackend
        direct2d

        AzureFallbackCanvasBackend
        cairo

Comment 5

5 years ago
(In reply to Alice0775 White from comment #3)
> (In reply to Masatoshi Kimura [:emk] from comment #1)
> > I couldn't find the garbled character. Could you be more specific?
> > (But surely some warnings are displayed to the Web Console.)
> 
> See screen shot attachment 706258 [details]

What image format is that?  Can you load a PNG or switch the MIME type?

Comment 6

5 years ago
Testing with:
Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20130122 Firefox/21.0

The PDF in the description loads and the first few pages load, followed by blank pages.  When scrolling, up and down, different pages appear and disappear(!!!), very weird.

Updated

5 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
(Reporter)

Comment 7

5 years ago
Created attachment 706275 [details]
screenshot

(In reply to John Daggett (:jtd) from comment #5)
> (In reply to Alice0775 White from comment #3)
> > (In reply to Masatoshi Kimura [:emk] from comment #1)
> > > I couldn't find the garbled character. Could you be more specific?
> > > (But surely some warnings are displayed to the Web Console.)
> > 
> > See screen shot attachment 706258 [details]
> 
> What image format is that?  Can you load a PNG or switch the MIME type?

oops.
(Reporter)

Updated

5 years ago
Attachment #706258 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Whiteboard: [pdfjs-c-rendering][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/2581
(Assignee)

Comment 8

5 years ago
Missing text and garbled characters problem is only Windows 7 issue with DirectWrite 6.1.

(In reply to John Daggett (:jtd) from comment #6)
> Testing with:
> Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0)
> Gecko/20130122 Firefox/21.0
> 
> The PDF in the description loads and the first few pages load, followed by
> blank pages.  When scrolling, up and down, different pages appear and
> disappear(!!!), very weird.

Does not fit description of this bug.
OS: All → Windows 7
Hardware: All → x86_64
(Reporter)

Comment 9

5 years ago
Reproduced on Ubuntu.
http://image.haier.com/manual/japan/wash_machine/201211/P020121130574743273239.pdf

http://hg.mozilla.org/mozilla-central/rev/bc108d2ce8d1
Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20130206 Firefox/21.0a1 ID:20130206031027
OS: Windows 7 → All
(Reporter)

Updated

5 years ago
tracking-firefox19: --- → ?
tracking-firefox20: --- → ?
tracking-firefox21: --- → ?
We should try to fix for FF20, but we do expect minor rendering issues with PDF.js in this first release. I'm happy to see that the yellow warning bar came down properly.
Assignee: nobody → ydelendik
status-firefox19: --- → wontfix
tracking-firefox19: ? → -
tracking-firefox20: ? → +
tracking-firefox21: ? → +

Comment 11

5 years ago
The first link of the first comment:
http://ybb.softbank.jp/support/connect/adsl/pdf/4g_set03.pdf

now is almost OK but seems to have the same bug with bug 770409
Vertical characters in the document are strange.

So what kind of bug is this bug 834286 now referring to?
What kind of garbled texts issues should I report here?

Should we speak about the garbled texts seen in
http://image.haier.com/manual/japan/wash_machine/201211/P020121130574743273239.pdf
?

Or is any PDF ok if it is a Japanese PDF and has garbled texts?

Then,
the first page of
http://www.project2061.org/publications/sfaa/SFAA_Japanese.pdf
is garbled.

http://kanji.zinbun.kyoto-u.ac.jp/~yasuoka/publications/JST2007-5.pdf#page=2
also has four garbled texts. Please open it in Adobe Reader as well and compare.

I am not sure what is the cause of garbled texts so I can not decide if these pdfs are related with this bug.
(Assignee)

Updated

5 years ago
Assignee: ydelendik → nobody

Updated

5 years ago
Keywords: intl, jp-critical
Hardware: x86_64 → All
Yury, assigning to you based on your whiteboard tag saying this is fixed upstream - can you mark the bug resolved and/or nominate for uplift when this is ready?
Assignee: nobody → ydelendik
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 842589

Updated

5 years ago
status-firefox20: --- → fixed
status-firefox21: --- → fixed

Comment 15

5 years ago
I am testing with pdf.js 0.7.283 on Firefox 20 beta2. But it seems to me that 

http://image.haier.com/manual/japan/wash_machine/201211/P020121130574743273239.pdf
http://www.project2061.org/publications/sfaa/SFAA_Japanese.pdf
http://www.paloma.co.jp/cmsfile/product/PCR-500E_M_A8.pdf
http://www.info.pmda.go.jp/downfiles/md/PDF/820038_16000BZZ01070000_A_01_05.pdf

still show garbled texts problems.

To be sure, they show chinese characters but they are not Japanese sentences. We Japanese can not understand them.
How should I do in order to comfirm if this has really been fixed.

Comment 16

5 years ago
I tested again with pdf.js 0.7.301 on Firefox beta2. The problems seen in two of the above 4 PDFs have been solved, I confirm, but the remaining two of PDFs still show problems.

http://image.haier.com/manual/japan/wash_machine/201211/P020121130574743273239.pdf
shows garbled texts.
And
http://image.haier.com/manual/japan/wash_machine/201211/P020121130574743273239.pdf
shows missing text problems.

Comment 17

5 years ago
I tested again with pdf.js 0.7.325, and I see the improvements.

But
http://www.jica.go.jp/hiroba/menu/ngo_enhance/pdf/group_nagoyango.pdf
http://www.chotatsu.e-aichi.jp/portal/pdf/1/4.6.1.pdf
still show missing text problems.
You need to log in before you can comment on or make changes to this bug.