Closed Bug 842589 Opened 10 years ago Closed 10 years ago

pdf.js missing character in Firefox19 and 20.0a2 with HWA enabled

Categories

(Firefox :: PDF Viewer, defect)

19 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox19 - wontfix
firefox20 + verified
firefox21 --- verified

People

(Reporter: alice0775, Assigned: yury)

References

()

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion] https://github.com/mozilla/pdf.js/pull/2581)

Attachments

(2 files)

Attached image screenshot
Build Identifier:
http://hg.mozilla.org/releases/mozilla-release/rev/20238b786063
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0 ID:20130215130331
http://hg.mozilla.org/releases/mozilla-aurora/rev/b9d8e56a0a96
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20130218 Firefox/20.0 ID:20130218042018

STR
Open url
Fixed window(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/bc108d2ce8d1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130205 Firefox/21.0 ID:20130205224345
Good:
http://hg.mozilla.org/mozilla-central/rev/04e13fc9dbff
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130207 Firefox/21.0 ID:20130207030936
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bc108d2ce8d1&tochange=04e13fc9dbff

Fixed window(m-i)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/66cb15452ab9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130205 Firefox/21.0 ID:20130205150942
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7f82f74de11f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130205 Firefox/21.0 ID:20130205151742
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=66cb15452ab9&tochange=7f82f74de11f

Bug 835954 will fix the problem
Depends on: 835954
Yury - is there a low risk fix we could uplift to FF20 for this issue?
Assignee: nobody → ydelendik
Flags: needinfo?(ydelendik)
Perhaps #2581 fixed this because HWA settings affect the bug.
(In reply to Alex Keybl [:akeybl] from comment #2)
> Yury - is there a low risk fix we could uplift to FF20 for this issue?

We can uplift only the commit that fixed the issue (see below). That's a low risk, but can affect all platforms. I can submit the patch for it.

(In reply to Masatoshi Kimura [:emk] from comment #3)
> Perhaps #2581 fixed this because HWA settings affect the bug.

That's correct. https://github.com/brendandahl/pdf.js/commit/dc914fe7ce8f362cfddfa5bb58877043d55dfe1b

See/test the try submission at https://tbpl.mozilla.org/?tree=Try&rev=746c17cc65f1
Flags: needinfo?(ydelendik)
[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: missing character in FF/Win when HWA enabled
Testing completed (on m-c, etc.): Tested on FF21, see also https://tbpl.mozilla.org/?tree=Try&rev=384128b34164
Risk to taking this patch (and alternatives if risky): low risk, effects all platforms
String or UUID changes made by this patch:
Attachment #717507 - Flags: review?(bdahl)
Attachment #717507 - Flags: approval-mozilla-beta?
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion] https://github.com/mozilla/pdf.js/pull/2581
Would be great to get this in an early beta - waiting on review to uplift and close the loop here.
Duplicate of this bug: 834286
(In reply to Lukas Blakk [:lsblakk] from comment #6)
> Would be great to get this in an early beta - waiting on review to uplift
> and close the loop here.

This patch is already reviewed upstream and merged on m-c by bug 835954. What kind of review do you suppose?
Attachment #717507 - Flags: review?(bdahl) → review+
Comment on attachment 717507 [details] [diff] [review]
Fixes missing character when HWA enabled (FF20)

The patch was waiting for review, that was what my comment was referring to.  Now that this is reviewed please go ahead with uplift to mozilla-beta repo.
Attachment #717507 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Keywords: checkin-needed
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion] https://github.com/mozilla/pdf.js/pull/2581 → checkin for attachment 717507 for mozilla-beta [pdfjs-c-rendering][pdfjs-d-font-conversion] https://github.com/mozilla/pdf.js/pull/2581
https://hg.mozilla.org/releases/mozilla-beta/rev/acbe0689b25a
Status: NEW → RESOLVED
Closed: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: checkin for attachment 717507 for mozilla-beta [pdfjs-c-rendering][pdfjs-d-font-conversion] https://github.com/mozilla/pdf.js/pull/2581 → [pdfjs-c-rendering][pdfjs-d-font-conversion] https://github.com/mozilla/pdf.js/pull/2581
Target Milestone: --- → Firefox 21
I can't reproduce this issue neither with Firefox 19, nor with a Nightly from 2013-02-05.

All the red parts from the screenshot attached in the description work fine for me: the text is displayed properly.  Though, I do get the notification that says that "This PDF document might not be displayed correctly."

Any suggestions would be appreciated.
QA Contact: manuela.muntean
Verified the fix on latest Aurora build:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130228 Firefox/21.0, BuildID: 20130228042012

Waiting for the next beta build (20.0 beta 3) to verify as it didn't make it for 20.0 beta 2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

Verified the fix on latest Firefox 20.0 beta 3.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.