Closed Bug 834400 Opened 7 years ago Closed 7 years ago

Wrong callback contexts used in aboutDownloads.js

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 21
Tracking Status
firefox20 --- fixed

People

(Reporter: bnicholson, Assigned: bnicholson)

References

Details

Attachments

(1 file)

We forgot a few binds() calls, so logError() won't work. This fixes them.
Attachment #706006 - Flags: review?(wjohnston)
Attachment #706006 - Flags: review?(wjohnston) → review+
Comment on attachment 706006 [details] [diff] [review]
Use bind() in download callbacks

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 820491
User impact if declined: some download manager errors won't be output correctly (like bug 834048)
Testing completed (on m-c, etc.): just landed m-i
Risk to taking this patch (and alternatives if risky): very low risk
String or UUID changes made by this patch: none
Attachment #706006 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/07592e6d5c23
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Attachment #706006 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.