Closed Bug 834714 Opened 8 years ago Closed 8 years ago

running browser_dbg_createChrome.js in an ubuntu vm fails

Categories

(DevTools :: Debugger, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 21

People

(Reporter: jmaher, Assigned: jmaher)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

this is the only browser chrome test case that fails while running inside an ubuntu 12.04 virtual machine.  I spent a day trying to debug this and didn't get anywhere.  We need somebody to look at this.


Here is what we see in the log:

12:42:56     INFO -  TEST-START | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js
12:42:56  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | uncaught exception - uncaught exception: 2147746065 at :0
12:42:56  WARNING -  This is a harness error.
12:42:56     INFO -  Stack trace:
12:42:56     INFO -      JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 1067
12:42:56     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
12:42:56     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | Console message: [JavaScript Error: "uncaught exception: 2147746065"]
12:43:26  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | Test timed out
12:43:26  WARNING -  This is a harness error.
12:43:26     INFO -  args: ['/builds/slave/test/build/tests/bin/screentopng']
12:43:26     INFO -  Xlib:  extension "RANDR" missing on display ":0".
12:43:29  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | Cleanup function threw an exception at chrome://browser/content/tabbrowser.xml:1536 - TypeError: aTab is null
12:43:29  WARNING -  This is a harness error.
12:43:29     INFO -  INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | finished in 30058ms
12:43:29  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_createChrome.js | Found a tab after previous test timed out: http://example.com/browser/browser/devtools/debugger/test/browser_dbg_stack.html
12:43:29  WARNING -  This is a harness error.
12:43:29     INFO -  TEST-INFO | checking window state


https://tbpl.mozilla.org/php/getParsedLog.php?id=19101423&tree=Cedar#error0
Blocks: 834725
FTR, This VM uses Xvfb for X.
Blocks: 837020
this is blocking us from migrating over our browser chrome test.  Can somebody from the developer tools team lend a hand to aid in fixing this?
I tried running the test in an Ubuntu 12.10 VirtualBox VM I have here and the test completed successfully. I ran the test using mach:

./mach mochitest-browser browser/devtools/debugger/tests/browser_dbg_createChrome.js

If that is not how you ran the test, can you try this so we can see if its specific to the way you set up the environment?

Comment 1 mentions using Xvfb, but it's been years since I used that, so perhaps one of you guys could save me some time by posting the steps required to do that?
you can run Xvfb like this:

$  Xvfb :0 -screen 0 1600x1200x24

Generate vnc password (need tightvncserver package):
$ vncpasswd

Then attach x11vnc
$ x11vnc -display :0 -rfbauth ~/.vnc/passwd -forever -shared

Now you can VNC to that host, something like this:

$ vncviewver -via $user@$host localhost
we run the tests the same way they do in automation from buildbot (i.e. there is no source tree or toolchain on the box).

I download a tar.bz2 and a tests.zip file from a build directory (i.e. http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux/1360077863/)

I unzip them, then I run the command:
python mochitest/runtests.py --appname=firefox/firefox-bin --utility-path=bin --extra-profile-file=bin/plugins --certificate-path=certs --autorun --close-when-done --console-level=INFO --symbols-path=http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux/1360077863/firefox-21.0a1.en-US.linux-i686.crashreporter-symbols.zip --browser-chrome

I will look at the mach command locally and see how it differs, there might be something I can do to copy all the necessary bits to the machine.
I figured this out.  We are trying to setup the debuggerserver port on 6000 and that is the port that xfvb is listening on.  

I was able to get this test passing by changing the pref devtools.debugger.remote-port to something else (I chose 6023).

Are there any concerns with my adding this new pref/setting to our automation script?
I am fine with that, thanks!
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Attachment #711926 - Flags: review?(past)
Attachment #711926 - Flags: review?(past) → review+
https://hg.mozilla.org/mozilla-central/rev/3634c136a68b
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.