Last Comment Bug 834870 - Cannot Right Click on Bookmarks (in Bookmarks Toolbar) if they are "Inside a folder" or under "Show more bookmarks" in OS X
: Cannot Right Click on Bookmarks (in Bookmarks Toolbar) if they are "Inside a ...
Status: RESOLVED DUPLICATE of bug 300710
[bugday-20130923]
:
Product: Firefox
Classification: Client Software
Component: Toolbars and Customization (show other bugs)
: 18 Branch
: x86_64 Mac OS X
: -- normal with 5 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-25 13:20 PST by Letian Grabo
Modified: 2013-09-23 13:13 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Letian Grabo 2013-01-25 13:20:44 PST
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

In Mac OS X 10.8.2, i tried to right click on bookmarks in "Bookmarks Toolbar" which are "Inside a folder" or under "Show more bookmarks" to delete or rename them


Actual results:

Nothing Happened! like i didn't right click at all
but if bookmark is not in a folder and is not under show more bookmarks its ok and i can right click


Expected results:

to delete a bookmark inside a folder i have to drag it outside and then right click and delete it, shouldn't we be able to right click on bookmarks inside folders and delete them there?
Comment 1 Cornel Ionce [QA] (:cornel_ionce) 2013-01-29 02:43:05 PST
Reproduced on Nightly 21.0a1

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20130128 Firefox/21.0
Build ID: 20130128030943

Note: on Windows 7 x64 this issue is not reproducing.
Comment 2 Lincoln 2013-03-11 13:04:47 PDT
This issue is my personal Groundhog Day.

It has never, ever worked on OSX.
It has *always* worked on Windows.

I've seen it reported multiple times, always to be marked as a duplicate of something completely unrelated or scuttled as irrelevant by a developer who doesn't understand the issue. I personally commented on one iteration in 2008 when it drove me to switch browsers, and I can find no record of it ever existing.

"I've got you, babe..."
Comment 3 Letian Grabo 2013-03-11 20:16:08 PDT
(In reply to Lincoln from comment #2)
> This issue is my personal Groundhog Day.
> 
> It has never, ever worked on OSX.
> It has *always* worked on Windows.
> 
> I've seen it reported multiple times, always to be marked as a duplicate of
> something completely unrelated or scuttled as irrelevant by a developer who
> doesn't understand the issue. I personally commented on one iteration in
> 2008 when it drove me to switch browsers, and I can find no record of it
> ever existing.
> 
> "I've got you, babe..."


Well i searched a lot
and found a solution (kind of)

Go to about:config in your browser (type and enter it in Address Bar)
Search for: ui.click_hold_context_menus
Double click to set it TRUE
Restart

then "LEFT"-Click and hold (not right click) and wait for menu
the only problem is when you release it, it click on the item under it
so you have to right click near the edges

well thats at least something!

BUT THERE IS NO PROBLEM ON CHROME! SO THIS IS A HUGE FIREFOX BUG NO ONE LIKES TO FIX!

OS X 10.8.2
Firefox 19.0.2
Comment 4 Walter 2013-06-23 08:27:00 PDT
I, too, have this issue, and it drives me nuts! I'd like to use Firefox for all of my browsing, but this puts a damper on simple bookmark management & organization (forcing you to pull up the bookmark library in another window to make a simple change).

This, Bug #289384, Bug #431544, and the lack of H.264 support on Mac drives me more often than I'd like to Chrome to get things done reliably. As much as I like Firefox, some of these issues have hung around long enough that if Chrome had a Tree Style Tabs add-on like Firefox, I'd probably start using it as my primary browser at this point.
Comment 5 Chris DeCairos (:cade) 2013-08-07 13:21:36 PDT
This is one of my biggest pet peeves with Firefox. I'm considering fixing this myself...
Comment 6 [:Aleksej] 2013-09-23 13:11:48 PDT

*** This bug has been marked as a duplicate of bug 300710 ***

Note You need to log in before you can comment on or make changes to this bug.