Last Comment Bug 835064 - Firefox 18 won't drag text on some installations.
: Firefox 18 won't drag text on some installations.
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: 18 Branch
: x86_64 All
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-26 10:42 PST by Luke
Modified: 2013-04-14 13:00 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
dd.htm (1.04 KB, text/html)
2013-01-26 10:42 PST, Luke
no flags Details

Description Luke 2013-01-26 10:42:31 PST
Created attachment 706796 [details]
dd.htm

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130117041608

Steps to reproduce:

In a certain web app, text is not draggable on some (not all) computers using Firefox 18 or 18.0.1. The bug happened to me on a Windows 7 pc, and a Linux laptop, though it didn't happen on a coworker's Windows machine. I have attached a minimal example page showing the problem.


Actual results:

In this example, the text should be draggable, to move to anywhere on the canvas. In every other browser, this example should work fine (Webkit, Opera, even IE). You can drag multiple times, moving anywhere on the canvas. In Firefox however, sometimes it didn't work at all, sometimes you must drag the area below the text to move it.

I did find one solution to this problem: going to about:config and setting "gfx.canvas.azure.enabled" to false fixes it.


Expected results:

All Firefox installs should be able to run this example page without having to change an obscure setting in about:config.
Comment 1 Cornel Ionce [QA] 2013-01-29 05:15:27 PST
Reproducing on nightly builds.
User Agents: 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130128 Firefox/21.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20130128 Firefox/21.0

Build ID: 20130128030943

Also, setting the "gfx.canvas.azure.enabled" to false fixes the problem, just like Luke reported.
Comment 2 Luke 2013-02-07 16:07:29 PST
According to this, Firefox 19 will not have the Azure fallback compatibility option?

http://news.softpedia.com/news/Firefox-18-Uses-Azure-Canvas-by-Default-for-Faster-Graphics-299351.shtml

Will this mean Firefox 19 will not have this workaround option to fix this issue?
Comment 3 Luke 2013-02-15 07:48:56 PST
I don't know if this helps, but here is the troubleshooting info from my about:support page, under graphics:

Graphics
        
Adapter Description Intel Open Source Technology Center -- Mesa DRI Intel(R) 965GM x86/MMX/SSE2
Device ID Mesa DRI Intel(R) 965GM x86/MMX/SSE2
Driver Version 2.1 Mesa 9.0
GPU Accelerated Windows 0/1 
Basic Vendor ID Intel Open Source Technology Center
WebGL Renderer Intel Open Source Technology Center -- Mesa DRI Intel(R) 965GM x86/MMX/SSE2
AzureCanvasBackend cairo
AzureContentBackend none
AzureFallbackCanvasBackend none

I tried turning off hardware acceleration, that didn't fix it either, and it seems there is no option to make this work in Firefox 19 preview. I really hope this is fixed in Firefox 19, since rewriting web apps from Kinetic.js 3 to 4 is a significant task, and some features in 3 have not been implemented in the latest Kinetic.js 4.

Best regards
Luke
Comment 4 Luke 2013-02-23 19:29:02 PST
Here's the info in about:support, Graphics, for one machine on which this feature was working properly:

Adapter Description
Intel(R) HD Graphics
Adapter Drivers
igdumd64 igd10umd64 igdumdx32 igd10umd32
Adapter RAM
Unknown
Device ID
0x0042
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
Driver Date
1-10-2012
Driver Version
8.15.10.2622
GPU #2 Active
false
GPU Accelerated Windows
1/1 Direct3D 10
Vendor ID0x8086
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics)
AzureCanvasBackend
direct2d
AzureContentBackend
direct2d
AzureFallbackCanvasBackend
cairo
Comment 5 Luke 2013-02-23 20:46:31 PST
Here's another Windows machine not working:
  Graphics:

        Adapter Description
        ATI RADEON XPRESS 200 Series

        Adapter Drivers
        atiumdag atiumdva atitmmxx

        Adapter RAM
        Unknown

        Device ID
        0x5a61

        Direct2D Enabled
        Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.

        DirectWrite Enabled
        false (6.1.7601.17789)

        Driver Date
        6-2-2008

        Driver Version
        8.501.0.0

        GPU #2 Active
        false

        GPU Accelerated Windows
        0/1 Basic Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.

        Vendor ID
        0x1002

        WebGL Renderer
        Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.

        AzureCanvasBackend
        cairo

        AzureContentBackend
        none

        AzureFallbackCanvasBackend
        none

I tested another Windows pc with this problem, which also had WebGL Renderer: unknown, GPU Accelerated Windows 0/1 Basic Blocked, cairo Azure-backend, and no Direct2d/DirectWrite Enabled.

Perhaps this bug is caused by a bug in Cairo, or Firefox's fallback for not fully-supported graphics?
Comment 6 Luke 2013-02-28 22:49:55 PST
I have narrowed down the source of the problem with mozregression:

Last good nightly: 2012-10-02
First bad nightly: 2012-10-03

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=85dd8e346102&tochange=635fcc11d2b1
Comment 7 Luke 2013-03-04 09:04:35 PST
According to mozregression:

The first bad revision is:
changeset:   108887:a16dfb364f8c
parent:      108886:da5df2c1ae16
parent:      108828:c9a8f55d8541
user:        Ed Morley <emorley (at) mozilla.com>
date:        Tue Oct 02 11:19:03 2012 +0100
summary:     Merge mozilla-central to mozilla-inbound
Regression found using mozcommitbuilder 0.4.10 on linux2 at 2013-03-04 16:45:33
Comment 8 Luke 2013-03-06 08:01:30 PST
Hg bisect on that branch finds this to be the problem:

The first bad revision is:
changeset:   108853:aa73f5544e07
user:        Anthony Jones <ajones (at) mozilla.com>
date:        Mon Oct 01 22:12:13 2012 -0400
summary:     Bug 795135 - Fix CairoTempMatrix restore. r=joe
Comment 9 Jonathan Brazil 2013-03-12 03:50:41 PDT
Just encountered this bug also and can confirm that it is preventing the draggable nature of Kinetic Text objects on a Windows platform. Using the general release builds of Firefox 18.0.1, 18.0.2, and 19 all function perfectly on OSX. However, the same general release versions of Firefox on Windows XP (only platform tested), all exhibit the issue of undraggable Kinetic Text objects. No errors are observed in the console; silent failure.

I can also confirm that setting the gfx.canvas.azure.enabled option to false on general release 19.0.2 did not resolve the issue.

Hopefully this is a quick fix.
Comment 10 Luke 2013-03-12 20:03:13 PDT
Hi Jonathan, 

I noticed recently that the Firefox 20 beta does not have this issue, the Cairo Azure bug has been fixed.

I've been using the beta for about a week, it seems more stable and fast than the current 19 release and also has a great new downloader. :)
Comment 11 Jonathan Brazil 2013-03-13 07:16:42 PDT
Thanks for the update Luke. I will try to get a copy of v20 and see what happens.

(In reply to Luke from comment #10)
> Hi Jonathan, 
> 
> I noticed recently that the Firefox 20 beta does not have this issue, the
> Cairo Azure bug has been fixed.
> 
> I've been using the beta for about a week, it seems more stable and fast
> than the current 19 release and also has a great new downloader. :)

Note You need to log in before you can comment on or make changes to this bug.